• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 525
  • Last Modified:

Archive process is on but archive logs do not show in destination unless a manual switch is done.

* We are using Oracle 10g Rel. 1 on AIX.  
* We have our archive destination set to "/u02/oracle/admin/blah/arch/blah1".
*  In v$instance, ARCHIVER is set to "STARTED".  
* The owner of the archive directory, at the UNIX level is "oracle dba".  
* The permissions on "/u02/oracle/admin/blah/arch/blah1" are drwxr-sr-x.
* The alert.log file shows the ARC1 process creating local archive destination LOG_ARCHIVE_DEST_1: '/u02/oracle/admin/blah/arch/blah1/blah1_####-###### sequence ####) (blah1) and also later on closing the same file.
* The last ARC1 archivelog created today was at 04:04:29
* At 07:05:00 a crontab job executes "alter database backup controlfile to trace", which should have no affect on the archive log files.
* There are NO ".arc" files in our archive log destination
* When I do a manual "alter system switch logfile", the ".arc" file that is created IS in the archive log destination.

Does anyone have a clue as to what may be happening to our archive log files that are created from ARC1 process?  The only ones that are in our archive log destination are those that are created when a manual switch is completed.
0
cbetter
Asked:
cbetter
1 Solution
 
Guy Hengel [angelIII / a3]Billing EngineerCommented:
archive log files are only created when a redo log file group is full, or, if the archive settings are configured, after x time, or x mb to be written.
so, if there is no traffic (UPDATE, INSERT, DELETE ...) on the database, then, getting an archive log file can take some time.
0
 
konektorCommented:
are there enough data writes ? check how offten log switch occurs in alertSID.log
is your database in ARCHIVELOG mode?
0
 
cbetterAuthor Commented:
That's not the issue here.  In the ALERT LOG, there are references to 26 archive log files being created on just Oct 01!

We JUST actually found the problem!!!!   I went into my archive destination and the .arc file that I manually produced an hour ago was GONE!!!!

We had previously checked our crontab (while logged in as Oracle) and there were no jobs set up to run there that even remotely looked like a purge job.....BUT, we never thought to look in the ROOT crobtab jobs!  SOMEONE (which we think we know who may have done this) went in and added a job to remove ALL .arc files from the archive destination.  VERY DANGEROUS!!!!  Shame on them!!!  So......case solved & we'll be taking a full backup this evening!  Thanks for the input!
0
 
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now