We help IT Professionals succeed at work.

Outlook: Contacts not Automatically appearing when creating new email

fgict
fgict asked
on
489 Views
Last Modified: 2009-03-27
We have just installed a new MS Small business server with exchange email server running. However, the users can not automatically get access to their contacts e.g. when they click to write a new email  they start entering the email address but they are not prompted from the contacts as they were before.  They must now enter the full email address and only the next time around will Outlook recognise that it has already been entered. How can we get Outlook to recognise the list of contacts already in place?
Any help, greatly appreciated.
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2008

Commented:
Greetings fgict !

You need to enable Contacts Database As An Email Address Book

1. click Tools > Email Accounts
2. click on 'View or change existing directories or address books' option.
3. click 'Next'.
4. click on 'Add' button > 'Additional Address Books' option.
5. click 'Next'.
6. click on the 'Outlook Address Book' option.
7. click 'Next'.
8. click on 'Finish' button.

9. click on the 'Contacts' tab
10. right-click on the 'Contacts' option on the left-hand side (under 'My
Contacts').
11. click on the 'Properties' option - see multi-tabbed dialog.
12. click on the 'Outlook Address Book' tab.
13. ensure that the 'Show this folder as an e-mail address book' option is
selected.
14. click OK.

Your Contacts database should now be active as an e-mail address book.

http://domino.lancs.ac.uk/pub/usghelpdesk.nsf/9fb9e62b73055de48025680100698378/c8dbe9bb81766cf080256e5800438856?OpenDocument

Hope this helps, war1
Adrian WilsonTechnical Consultant / Project Manager
CERTIFIED EXPERT

Commented:
Hi,
 What you are describing is the Outlook nickname cache function rather than the Exchange Global contacts list resolution. This is normally stored in the following file in a user's profile (I'm guessing the users have new profiles or at least Outlook profiles). %Userprofile%\Application Data\Microsoft\Outlook\Outlook.NK2
The .NK2 for each user is probably a new file under a new profile after the SBS server went in?

For the global address list resolution you normally have to wait a little longer for resolution to pick up the name you are typing (if you press Ctrl + K, it will go off and resolve the name quicker).

HTH.
CERTIFIED EXPERT

Commented:
I found this a real problem until one of my cleints simply send a test message to everyone in her contacts list.
as you say outlook doesn't know about the email address unless you have send an email to that address.
also try:
I think its also something to do with which address book outlook uses - go to outlook /Tools/Address Book - then click on Tools/Options and see what its using
then goto tools/email accounts/ click on view address or directory and see what is being used.
I think if you tell outlook to use the same address book as the one with all the contacts in.

Author

Commented:
Hi all,

I did the following:
Tools > Email Accounts
clicked on 'View or change existing directories or address books' option. clicked 'Next'.
I removed the Outlook Address Book and replaced it with the Personal Address Book.

Then I did the following
Tools > Address Book > tools > Options >

Under the heading: "Show this address list first:" I choose "Contacts"

Now when I click to create a new email, when I click the to button my entire personal contact list shows up, but it still does not automatically pick up the list if I don't click "To" and continue typing. If I hit CTRL + K the list appears in  a popup window for the first letter entered.

Any other ideas?
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT
Top Expert 2008

Commented:
fgict,

Glad you got the new address book.  You may have to send an email to those you want to send to get the names in autofill, as chilternPC said.

Author

Commented:
@ chilternPC
Thanks, I used this walk-around by exporting the contacts to a csv file, then copying all the email addresses into a new message. I disconnected the internet connection so that the test message went into the outbox. I deleted the outbox message and re-connected the internet connection..and hey-presto all contacts are now coming up automatically. Thanks to all for their help.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.