• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 970
  • Last Modified:

When accessing Outlook Web Access other users mailbox's open without prompting username/passwords

The problem I'm having is that when I log in to any of the spare notebook pc's in our org and try to access Outlook Web Access it automatically opens someone elses mailbox without even prompting for a username and password. Now, I have to mention that all these notbooks use the same shared domain account created for this purpous.  

I also need to mention that despite the use of a secure certificate I also get the following access results::

(When inside the network) using "http" in the browser allows access to OWA too instead of access allowed only using "https" and browser proceeds to open users mailbox without prompting.

(When outside the network) again, both "http" and "https" work and I do get prompted for a username and password thus opening the correct mailbox.

Would anyone know or can help me troubleshoot why other users mailboxes open without prompting me for username and password when accessing OWA internally?

Thanks in advance,
Evan
0
ekitech
Asked:
ekitech
  • 3
  • 2
2 Solutions
 
flames1100Commented:
Someone may have a better way of doing this, but I know you can change security settings on the browser to get the prompt.  Go to Tools, Internet Options, Security tab, Custom Level (probably for Local Intranet), scroll to the bottom and change the last setting to prompt for username and password instead of automatic login.  That should do it.
0
 
flames1100Commented:
Sorry...assuming IE.
0
 
ekitechAuthor Commented:
TY for your reply!  Is there any way to do that at the server level so that setting can not be changed by the users?

...also (failed to mention), IE6 and 7 browers, Exchange Server 2003, XP clients

Thanks again!
0
 
flames1100Commented:
It appears you can do that with group policy a couple of ways.  You can do it under the Computer Configuration side, under Adminstrative Templates, Windows Components, Internet Explorer, Internet Control Panel, Security Page, Intranet Zone, Logon Options (configure to Prompt for Username and Password).  You can also import it under the User Configuration, but I'm not sure how that works.

Just for the record...I'm not a GPO guru by any means, so if anyone has any comments on doing this, please say so.  Hope this helps, though!
0
 
ekitechAuthor Commented:
Thanks for your help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Managing Security & Risk at the Speed of Business

Gartner Research VP, Neil McDonald & AlgoSec CTO, Prof. Avishai Wool, discuss the business-driven approach to automated security policy management, its benefits and how to align security policy management with business processes to address today's security challenges.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now