My Battlefield 1942, Desert Combat give error of wrong version trying to play on internet

My Battlefield 1942, Desert Combat give error of wrong version trying to play on internet.  
They seem to be fine in single player.
I dont know the patches and the order they need to be installed.  (A friend told me these errors come from installing the game and patches incorrectly.)
I need exact directions on how to install the software, and then the patches.  And which patches to install.
Thank you!!
Mark O'BrienDispatch Software Support and Server AdministrationAsked:
Who is Participating?
 
☠ MASQ ☠Connect With a Mentor Commented:
The correct order is:
- Install BF1942 from disk
- BF1942 v.1.6.19 patch (267MB ftp://largedownloads.ea.com/pub/patches/battlefield_1942_patch_v1.6.19.exe)
- BF1942 v.1.6.19-v1.61b patch ( 6.4MB ftp://largedownloads.ea.com/pub/patches/battlefield_1942_incremental_patch_v1.6_to_v1.61b.exe)
- Then install DC expansion from disk
- Then patch DC using the BF1942 DC 0.7- DC Final Patch (361MB http://battlefield2.filefront.com/file/Desert_Combat_Final_Client_Download;31620#Download)

0
 
and235100Commented:
My advice would be - uninstall the game fully - then before following MASQUERAID's advice - run CCleaner (http://www.ccleaner.com/download/) - just in case there is anything left behind after the uninstall that may interfere with the new install later on...
0
 
Mark O'BrienDispatch Software Support and Server AdministrationAuthor Commented:
Ok will try this.  Stand by please.....
Mark
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Mark O'BrienDispatch Software Support and Server AdministrationAuthor Commented:
Hi Masqueraid and And.  I uninstalled the game.  I didnt run the cleaner though.  I usually dont have problems when uninstalling/resinstalling.  So I reinstalled successfully, and then tried to install the 1st patch,  BF1942 v.1.6.19 patch, and I got the error:  "You have version 1.03.101 of BF 1942 installed.  This patch upgrades version 1.05.001.  Instalation with now close."  (OK)

What should I try next?
Thank you
Mark 88
0
 
and235100Commented:
Try this version - before 1.6:
http://www.gamershell.com/download_3977.shtml
(full version 1.5)
0
 
Mark O'BrienDispatch Software Support and Server AdministrationAuthor Commented:
Still in a holding pattern on this question.  Please stand by again..............
Thank you!!!  :)
0
 
Mark O'BrienDispatch Software Support and Server AdministrationAuthor Commented:
Thank you, Masqueraid
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.