DNS error only applies in VISTA help!!

Hello hope someone can help.

I have just bought a new PC with Windows Vista home basic edition installed.  I have set up a wireless network using a netgear ADSL router and USB pen.  The network works fine and both my PC and my laptop (which runs XP) can connect to the router wirelessley.  

The problem is connecting to the Internet.  My XP laptop does this fine as does a couple of other machines I have tried.  My VISTA machine however tells me that I have a DNS error.  When I click the option to diagnose this problem  get the following error message:

"Primary DNS Server" is not setup to establish connection on port "domain" with this computer.  As mentioned it is just the VISTA PC that will not conenct to the web.  I have tried allsorts and am now thinking of buying windows XP and installing that as I know it works but I dont like having to pay extra on top of my PC for the OS.  Please help.
LVL 4
graemeboroAsked:
Who is Participating?
 
captainCommented:
Hi

The USB pen works OK and is recognised by the OS? I very much think that this is a Vista message without a real meaning, all it tells you is that it cannot resolve the address in your browser...

As the other PCs work I take the DNS is handled by your Netgear, to check have a look at the Basic config page there should be an entry for DNS servers which is usually set to dynamic (or Get from ISP on some routers). Likelyhood is that the network has limited connectivity and you can see this in your Network and Sharing Center (which I hope they kept in Basic, as I have Ultimate here I am not sure)

If you go to the Windows Start Menu and type run in the search box and then CMD, type in IPCONFIG  /all at the prompt, when you get the results check the entry for your USB modem. The modem should have an IP from the same range then your routers DHCP chucks out. If it starts with 169 it is auto configuring and does not obtain an IP automatically. If it has a 192.168.x.x then it picks up the IP OK and the entry should have a default gateway with your router IP eg 192.168.x.1...

There are 2 options here, either the USB sticks connects to the router OK and not to the Internet (a) or does not connect to the router (b)

To fix (a) go to Network sharing center (NSC) and select Connect to a network, Windows will find your network and you can adjust the settings such as public or private. Select private network and allow Vista to make the changes for you, this will make any necessary changes to the firewall to enable traffic. Try again

(b) Check the driver for the USB modem, make sure you install it correctly to gain access to the router.
Go to the NSC and select setup connection to a network and follow the wizard. then follow steps (a)

There is more but try this first and let us know how you get on
cheers
0
 
Alan HendersonRetired marine engineerCommented:
Is the router compatible with Vista?
Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers.
A registry tweak to fix this is here:
http://support.microsoft.com/default.aspx?scid=kb;en-us;928233

Other Vista networking issues, though probably not directly related to your problem:
A common probem is that the default workgroup name in Windows Vista has been changed to Workgroup. In Windows XP, the default workgroup name is Mshome.

You need to change all PCs to the same name.

To change the name of the workgroup on Windows XP to match the name of your Windows Vista network:
In Windows XP, right-click My Computer,
click the Computer Name tab,
then click Change.
In the Workgroup box, type in the name of your Windows Vista network.
If you're leaving it as the default used in Windows Vista, type in Workgroup.
If you're not using the Windows Vista default, change it to whatever name you've given your Windows Vista network and click OK.

There's an excellent 3 page article here which may help you:
http://www.computerworld.com/action/article.do?command=viewArticleBasic&articleId=9019179&pageNumber=3

And here is an overview of Sharing in Vista:
http://www.microsoft.com/technet/network/evaluate/vista_fp.mspx
which may also help.

Also:
LLTD responder installation is necessary in XP computers in the network:
http://www.microsoft.com/downloads/details.aspx?FamilyId=4F01A31D-EE46-481E-BA11-37F485FA34EA&displaylang=en
0
 
Netman66Commented:
You may need to disable autotuning to get this to work.

From an elevated CMD prompt, run:

netsh interface tcp set global autotuninglevel=disabled

See if it works (may need a reboot).

If it makes no difference, set it back like this:

netsh interface tcp set global autotuninglevel=normal
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.