[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 285
  • Last Modified:

Web interface for OMA (http://servername/oma) gets Run time errors

When using IE to test Outlook Mobile Access I receive the following errors:

Server Error in '/OMA' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
I have applied the following articles with no results:

http://www.amset.info/exchange/mobile-eastrouble.asp
http://support.microsoft.com/kb/883380
http://www.amset.info/exchange/mobile-85010014.asp

Outlook Web Access works fine, no problems getting to that at all.
0
jefferybush
Asked:
jefferybush
  • 5
  • 4
2 Solutions
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Runtime errors of this type generally suggest that you have changed the .NET version on the default web site to 2.0.  It must remain at .NET 1.1 in order to work properly.

So, you can change it back in the properties of the default site, but you may also have to re-register .NET 1.1

Run this at a command prompt:   C:\Windows\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i -enable

Jeff
TechSoEasy
0
 
jefferybushAuthor Commented:
Thanks for the response, Tech. You are right, the .net version was 2.0. I changed it and applied the command, no change. The .NET version remains at 2.0 for the rest of the virtual directories. Is this causing the problem, and if so, will I have to recreate the virtual directories to get this to work?

Jeff
0
 
SembeeCommented:
Exchange 2003 is a 1.1 application. All of the Exchange virtual directories should be 1.1 - although if the others were wrong then I would expect OWA to fail as well.

Have changing them, run iisreset from a command prompt. This restarts IIS and writes the change to the metabase.

Simon.
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
jefferybushAuthor Commented:
Thanks, Sembee. I can't change the individual directories because the option is grayed out, hence my question about rebuilding the directories again.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
If you have no need for .NET 2.0 on your server uninstall it for now.

Jeff
TechSoEasy
0
 
jefferybushAuthor Commented:
Hmmm....Out of the frying pan as they say. I seem to be missing the tab for ASP.NET 0 in my default web site properties after removal of .net 2.0. Any ideas, Sembee?
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Are you saying you don't want any ideas from anyone else?
0
 
jefferybushAuthor Commented:
No, I have absolutely no problem getting ideas from others. =).Let me rephrase. Anyone have any ideas?
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
So, you've removed .NET 2.0 so there shouldn't be any ASP.NET tab in the site properties because only .NET 1.1 would be there --- that's normal.

Did you run the re-register command I posted above?

If so, then be sure to delete any temporary Internet files on the machine you are testing this with and then test again.

Jeff
TechSoEasy
0
 
jefferybushAuthor Commented:
Thanks, Jeff-

Sorry it took so long to get back with you. Yes, I reran the command and I started getting a different error: Item no longer exists. The item you are attempting to access may have been deleted or moved. I went into the "exchange-oma" virtual directory and the local path was not correct. I changed it and Bingo! She's working again.

The solution you have provided was correct, most of this problem came from changing the .NET version from 1.1 to 2.0. I have backed up the default web site now that it's working properly so that I can restore it easily.

Thanks again for your help, and Sembee as well..
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now