We help IT Professionals succeed at work.

WSUS 3.0 not updating after successful sync.

1,873 Views
Last Modified: 2008-06-20
I have a Windows 2003 server fully patched and have installed sql 2005 express.  Everything seems to go well, the sync complets but the event viewer tells me that the server is failing to download some updates and Background:  Win 2003 server (not Small Biz, WSUS 3.0 fresh install)
I am not able to download updates after the sync says that it is succeeded.  Event log is telling me: ontent file download failed. Reason: The server does not support the necessary HTTP protocol. Background Intelligent Transfer Service (BITS) requires that the server support the Range protocol header.
 Source File: /msdownload/update/v3-19990518/cabpool/nldlpkop_2d61787a6b680a97d66784817d8847eb6deea490.cab Destination File: c:\WSUS\WsusContent\90\2D61787A6B680A97D66784817D8847EB6DEEA490.CAB.


We had a wsus 2.0 server that ran just fine and downloaded all updates with no issues.  We are not staying with it do to hardware upgrades.  

I have posted the question and thought that the issues had been fixed but i'm back to sq. 1.

Any help would be great!

Thanks,
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2005

Commented:
Was SQL Express already on the server before you installed WSUS?  or was it installed with WSUS?

Try this:

This problem occurs if your proxy environment doesnt support HTTP 1.1 Protocol. You can manually work around this by running the following commands at the command prompt to configure BITS.

 To resolve this issue:
 
 1.  Type: net stop WSUSService, and then press ENTER.
 
2.  Type: "%programfiles%\Update Services\tools\osql\osql.exe"  -S SQL_InstanceName -E -b -n Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1" and then press ENTER.
 
3.  Type: net start WSUSService.
 
4.  Close the command prompt window and retry synchronization: in the WSUS console, click Options, click Synchronization Options, and then under Tasks, click Synchronize now.
 
 
Reference:http://technet2.microsoft.com/windowsserver/en/library/5b2a029a-34bf-47ba-94e3-e0e93b4f825b1033.mspx?mfr=true
CERTIFIED EXPERT
Top Expert 2005

Commented:
That got butchered a bit:

2.  Type: "%programfiles%\Update Services\tools\osql\osql.exe"  -S SQL_InstanceName -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1" and then press ENTER.

Where SQL_InstanceName is the WSUS instance in SQL Express (normally SUSDB).


Author

Commented:
For whatever reason i do not have the osql folder under the tools folder.  I tried the windows internal db and now i have installed sql 2005 express.  during the wsus install told it to use the sql db.  any ideas???
CERTIFIED EXPERT
Top Expert 2005
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
I have ran the work around that this is what is returned:

[SQL Native Client]Named Pipes Provider: Could not open a connection to SQL
Server [2].
[SQL Native Client]Login timeout expired
[SQL Native Client]An error has occurred while establishing a connection to
the server. When connecting to SQL Server 2005, this failure may be caused by
the fact that under the default settings SQL Server does not allow remote
connections.
CERTIFIED EXPERT
Top Expert 2005

Commented:
The WSUS admin account needs access to the DB in SQL.  This is why I say that unless you're a DB Admin and understand how the instances and access need to be configured, then remove it all and install WSUS cleanly.

Author

Commented:
I have reinstalled all of WSUS 3.0, report viewer, .net2 & 3.0 with all updates using windows internal database, and i am still running into the same issue of the server not downloading any updates after approval.  Any new ideas??

Commented:
I had the same problem and here is what fixed it

Open IIS Manager
If there is a WSUS Administration expand it to find the Content website.  If there is no WSUS Administration site then look for the Content site under the Default Website (the location of the Content Site depends on options during the install).

Right click content and go to properties.
Click the BITS Server Extension tab and check the Allow Clients to Transfer Data to this Virtual Directory check box.
Click OK
Restart IIS

Retry Download and check event log for errors.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.