• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4418
  • Last Modified:

Unmount NFS share on solaris

Hi All
I need to unmount a nfs share on a solaris server because the NFS server is down.

I tried
umount -f /share but it just freezes

I also tried
fuser -c /share to see what process might be using it..and that freezes too

Any guidance please ?
0
http:// thevpn.guru
Asked:
http:// thevpn.guru
  • 3
  • 2
3 Solutions
 
omarfaridCommented:
Hi,

Try this:

To unmount an NFS-mounted file system after the server has died:

1.  Do not execute any commands that access the NFS mount point, such as
     `df', or commands that try to read or write to that file system.

2.  Run `mount -v' to get the canonical name of the host and its exported
    file system (in the example above, "remoteserver:/").

3.  Run `fuser -k', giving it the canonical name reported by `mount -v':
    # fuser -k remoteserver:/

4.  Run `umount' to unmount the remote file system:
    # umount remoteserver:/

If the `umount' doesn't succeed, wait 5 or 10 minutes, then try `fuser -k'
and `umount' again.  This waiting period is a normal span for NFS regardless
of the implementing vendor.  It allows the I/O to time out, which returns an
error back to the program, unblocking it.
0
 
http:// thevpn.guruAuthor Commented:
The thing is that
fuser -k remoteserver:/ does not work because remoteserver is down
0
 
omarfaridCommented:
Hi,

But fuser is supposed to work on your server to identify processes that are having open files on that filesystem and then kill it. This is read from your server memory and not from the remote server.

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
http:// thevpn.guruAuthor Commented:
Yeah I know..but the error message it is throwing is the following

remoteserver:/ No such file or directory
0
 
omarfaridCommented:
Hi,

There could be a corruption in the mounted file systems table.

The following lines are taken from the man page of mount:

"
 The table of currently mounted file systems can be found  by examining  the mounted file system information file. This is provided by  a  file  system  that  is  usually  mounted  on
 /etc/mnttab.   The   mounted   file  system  information  is described in mnttab(4). Mounting a file system adds an entry to  the  mount  table;   a  umount removes an entry from the  table."

can you check the content of this file (it is text file)?

0
 
bpeterseCommented:
I just encountered the same situation on a Solaris server and what worked for me was
`fuser -k <name_of_locally_mounted_dir>`

I first tried the `fuser -k <remote_server>/<remote_path> but got the same error message as above....
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now