We help IT Professionals succeed at work.

IIS6 & Integrated windows authentication prompts login window !!!

1,857 Views
Last Modified: 2012-08-14
We have an intranet application running on healthcare.yourdomain.co.uk.

We have deployed this application in a server belonging to mydomain.com domain. We have configured this application to use integrated windows authentication.

We have configured this application in server100.mydomain.com. (NetBIOS name DOMAIN).
Windows 2003 SP2 & IIS6.

We have created one more DNS entry healthcare.yourdomain.co.uk pointing to server100.mydomain.com.

We have configured the website for healthcare.yourdomain.co.uk on server100.mydomain.com
And I have placed a header healthcare.yourdomain.co.uk.

Our users PCs are in mydomain.com. (NetBIOS name DOMAIN).Whenever user types healthcare.yourdomain.co.uk in IE they are prompted for login window, it never consider integrated windows authentication. When I enter DOMAIN\myuserid and password it comes up with the website.

But when we try to access the application using server100.mydomain.com (we have configured this application default website and configured server100.mydomain.com & healthcare.yourdomain.co.uk as host headers), no auth prompt is shown; users are directly logged into the application

Ideally, when we try to access healthcare.yourdomain.co.uk the authentication prompt should not have come and users should be seamlessly logged into the application. What is the resolution of this problem?

Our users in mydomain.com. (NetBIOS name DOMAIN) should be able to access healthcare.yourdomain.co.uk without any prompt (it should use integrated windows authentication).

Thoughts?
Comment
Watch Question

Ted BouskillSenior Software Developer
CERTIFIED EXPERT
Top Expert 2009

Commented:
I'm assuming you are using IE, Firefox doesn't have a fix for this and will always show a prompt dialog.

Any in IE if you look at the bottom right of IE it shows an icon for the current zone.  Intranet, Trusted or Internet are the standard three.  By default the automatic login for username and password will ONLY work for Intranet (local) sites.  However, for IE to decide that you are local is that the domain of the computer and the website have to be the same! (Which yours are not)

The only way to fix this is to change the IE policy settings so that the website is trusted and to autologon onto trusted sites.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Ted BouskillSenior Software Developer
CERTIFIED EXPERT
Top Expert 2009
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.