• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 13381
  • Last Modified:

Email fails with: 550 Warning - Reverse DNS lookup failed for host

Hello,

I am having a problem emailing a particular person, the email worked fine last week, but now when I try, I get this message back from my server:

-----------------------
Your message did not reach some or all of the intended recipients.

      Subject:      Conference
      Sent:      03/10/2007 16:36

The following recipient(s) cannot be reached:

      'email - deleted for privacy'' on 03/10/2007 16:36
            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <my email domain here #5.5.0 smtp;550 Warning - Reverse DNS lookup failed for host My server static IP here.>


I would appreciate some help to work out why.
When I check my domain for reverse DNS here: http://www.mxtoolbox.com/diagnostic.aspx it comes back ok..

Thanks
Jack
0
JackHodson
Asked:
JackHodson
1 Solution
 
SembeeCommented:
The message means what it says. You failed on a reverse DNS test.
Have you tested the reverse DNS using some of the online tools?
Does the reverse DNS entry match how the Exchange server announces itself?
You can see that by telnetting to port 25 of the Exchange server

telnet servername 25

and see what the banner says. If it says domain.com (instead of host.domain.com) or domain.local then you have a problem.

Simon.
0
 
JackHodsonIT ManagerAuthor Commented:
My result is:

telnet <exchange public IP> 25
Trying <exchange public IP>...
Connected to email.co.uk.
Escape character is '^]'.
220 infomedltd.co.uk Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at  Wed, 3 Oct 2007 21:48:25 +0100

So, I have a problem...how can I solve it?

Thanks
0
 
JackHodsonIT ManagerAuthor Commented:
Sorry, meant to change above, all instances of infomedltd.co.uk to email.co.uk - I guess it doesnt matter too much..
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
SembeeCommented:
I don't find any MX records for that domain anyway, so that could be a problem.

This is my guide on DNS configuration for an Exchange server, it should help:
http://www.amset.info/exchange/dnsconfig.asp

Simon.
0
 
JackHodsonIT ManagerAuthor Commented:
Hi Simon,

Not sure why you cant see the MX records for the infomedltd.co.uk - works for me: http://www.mxtoolbox.com/index.aspx

I did the SMTP telnet test - all OK.

The FQDN in Exchange System Manager is "infomedltd.co.uk" - not "mail.infomedltd.co.uk" as is written in your article.

If you check my MX record, you will notice that the instruction is to send it to infomedltd.dyndns.org (a service from http://www.dyndns.com as I am sure you know). The setting in DYNDNS then forward the email to the public IP address of my Exchange.

Is the above likely to cause a problem?

Should I be checking the reverse DNS setting for the domain name, or for the exchange public IP?

The result for the public IP of echange server from: http://www.dnsgoodies.com/

Server: 192.168.2.124
Address: 192.168.2.124#53

Non-authoritative answer:
234.106.73.194.in-addr.arpa name = infomedltd.co.uk.



Thanks
Jack
0
 
SembeeCommented:
Your use of the root for your domain is causing problems.

When I do an nslookup on infomedltd.co.uk I get 81.17.252.70. Yet when I do a reverse DNS lookup on that IP address I get iseult.blacknight.ie.

I don't recommend the use of the root for MX records as it causes these sorts of problems.

Therefore I would suggest the follow.
1. Get your domain name host to create a new host called mail in your domain, type A, and point it to the static IP address of your server.
2. Change your MX records so that mail.infomedltd.co.uk is priority 10. Change the others so that they are a higher priority.
3. Call your ISP and get the reverse DNS on your IP address for the Exchange server changed to mail.infomedltd.co.uk.
4. Change the SMTP banner to mail.infomedltd.co.uk - ESM, Servers, <your server>, Protocols, SMTP. Right click on the default SMTP VS and choose Properties. Click on the tab delivery and then advanced and change the FQDN. Be aware that each time you run the Connect to the Internet and email wizard (or whatever it is called) SBS will change it back to just infomedltd.co.uk, which is very annoying.

Simon.
0
 
JackHodsonIT ManagerAuthor Commented:
Hi Simon,

Many thanks, I will follow that list and complete.

Thought I should mention, this seems an issue with only one user as I notice today, I can send to the person whos email kept failing with: <my email domain here #5.5.0 smtp;550 Warning - Reverse DNS lookup failed for host My server static IP here.>

and today, another email address which she cant send to, but one which I can, the error is:

Your message did not reach some or all of the intended recipients.

      Subject:       Booking Confirmation

The following recipient(s) cannot be reached:

      recipientsname@hotmail.com  on 04/10/2007 15:14
            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <bay0-mc10-f23.bay0.hotmail.com #5.5.0 smtp;550 Requested action not taken: mailbox unavailable (907639705:2774:-2147467259)>


Could it be that this users mailbox is corrupt?

Jack
0
 
SembeeCommented:
Why would you think the mailbox is corrupt? The NDR has been generated by a server at Hotmail. It has nothing to do with your server.

Simon.
0
 
ridCommented:
I think the bounce message is generated by the sender server, but it refers to the hotmail server as responsible for giving the 550 failure.

Either the user doesn't exist, or the username (adressee) is misspelled, or there's another type of rejection taking place but the failure message is not "spot-on".
/RID
0
 
JackHodsonIT ManagerAuthor Commented:
I think this because, I am able to send to this hotmail address but my colleague is not, to me that suggests the problem is with my colleagues mailbox. I know the hotmail address exists as we were replying to a message sent to us.

Other thoughs are that Sophos and PureMessage could be affecting things. I will keep an eye.

Jack
0
 
waters_philCommented:
I get this error from ing.wanadoo.es even though I do have a reverse DNS entry. I wonder if some mail hosts look up the reverse DNS entry and then take the FQDN and see if the forward entry matches (which is not the case for me)

Again, i verified that latinmail.com's dns server (wanadoo) could look up my DNS entry in reverse, but the problem still occurs. The problem doesn't occur on a mail server whose reverse DNS entry and forward DNS entry match.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now