?
Solved

BIOS Flash problem - Failure to load ACPI

Posted on 2007-10-03
11
Medium Priority
?
2,413 Views
Last Modified: 2013-11-09
Hi Experts,
I recently updated the BIOS on the Abit AB9 Pro board using the Windows utility from ABIT, however, after the BIOS updated successfully, I noticed that the computer started to hang. I then decided to re-flash the Bios with the backed up BIN file. The problem I have now is that the computer hung while the BIOS was updating (at 60%), and I had no option but to restart. On restarting Windows Vista will not work and it goes into the 'Windows Boot Manager' screen with the following error:
Status: 0xc0140019
Info: Windows failed to load because the ACPI firmware (BIOS) RSDP table is invalid.
It seems that this problem is caused because the BIOS did not complete loading.
I do not have a floppy drive on the computer. Would really appreciate aome help in getting this resolved and the computer working again (by the way, I am unable to enter the BIOS when I select the Delete button on POST).
Thanks
Sam
0
Comment
Question by:samirst
  • 5
  • 2
  • 2
  • +2
11 Comments
 
LVL 3

Expert Comment

by:jkpc21
ID: 20008380
Since you can't get into the bios or windows, it seems as though your options are limited.

You might want to try resetting the bios by removing the battery or you may want to look in the motherboard manual to see which jumpers to adjust in order to reset... its a long shot, but can't really make anything worse than it already is.

Also, you can purchase a USB floppy drive and flash the bios using the floppy disk. Most motherboard manufacturers have utilities you extract onto a floppy and you flash your bios that way by booting to the floppy.
0
 

Author Comment

by:samirst
ID: 20008460
Do I need the BIOS loading before booting via USB?
0
 
LVL 3

Expert Comment

by:jkpc21
ID: 20008569
Not sure what you mean by saying "do i need the bios loading before booting via USB"  How far are you getting during the boot up process before getting any errors?

Once you have the floppy ready and connected to the computer, start the computer and press F12 to get the 1 time boot menu (some computers are set to boot from the floppy as their first boot device) select the floppy and have it run the utilities that are on the floppy. If i understand everything correctly, and you have done everything correct on your part, at this point the computer should be booting from the floppy and you should start seeing thing that indicate the abit utilities to flash the bios are being loaded.

Make sure you read the directions on how to create the boot floppy from abit.

Hope this helps.
0
Meet the Family that is Made for Collaboration

The TeamConnect Family product group as part of the Sennheiser for Business Portfolio comprising high-quality, technically well-conceived meeting solutions for business communication – designed for any meeting room and any meeting situation.

 

Author Comment

by:samirst
ID: 20008716
It gets to the 'verifying DMI Pool data' and the error comes up straight after. Since I do not have a floppy on the computer, I will need to use a USB stick. Before the DMI Pool message. I will try HP BOOT Disk from the USB to see if it works. Do you know of a better utility to boot from USB?
Thanks
Sam
0
 
LVL 7

Expert Comment

by:sppalser
ID: 20010437
You should check with your MBD documentation to see if there is a keystroke sequence to default your BIOS to a minimal stable working condition that will then allow you to do your Flash update.  Some MBDs will have you press and hold the keystroke during a power on which will then trigger the MBD to use hard settings to then allow the BIOS flash.  This is not always documented in the literature that comes with the board so you may have to call Abit to see if there is anything like that.  Most of the boards I remember having to this on was to press and hold the [F10] key while powering on.

Good Luck
0
 
LVL 93

Expert Comment

by:nobus
ID: 20012333
check in your mobo if it has the flash recovery option - usually accessed thru a key sequence - on Asus boards, it is Alt+F2
other than that, you can try these :
http://www.recoverybios.com/                                    replace bios
http://www.badflash.com/                                        "          "
http://bioschips.nlan.org/                                    bad bios chip
http://www.unicore.com/                                    Bios upgrade
0
 

Author Comment

by:samirst
ID: 20012743
Thanks all. I have reset the CMOS using the jumpers on the board, and that did not help. I'll check with Abit to see if they have bios recovery key strokes. Will post update on progress.
0
 

Author Comment

by:samirst
ID: 20020776
Hi,
I made contact with Abit and there is no functionality to restore BIOS on board. The good news is I managed to boot from USB using HP Boot Disk, I am getting the 'bash-2.05b#' command prompt, and it does not accept any standard DOS commands to start the AWDFLASH applications. Any ideas how I can start this application. I have added it to the USB stick.
Thanks
0
 
LVL 32

Accepted Solution

by:
_ earned 2000 total points
ID: 20026595
From what I have read, it goes something like this:
1. get the HP usb boot program (you did that already)

2. Go to Bootdisk.com and  DL the Special Disk For Bios Flashing file (DRdflash.zip). You can find this with the DOS/WINDOWS9X BOOTDISKS link

3. Install the HP utility and extract the DRDFLASH.IMG file from wihin DRDFLASH.ZIP

4.Connect the flashdrive, and run the KEYBOOT utility. Select a drive letter, and then select Create New Or Replace Existing Configuration.

5. Choose Floppy Disk option, and Image From File. Go to where you have the DRDFLASH.IMG file, click next and Finish.

This should Format the flashdrive and install the boot image.. The Flashdrive should now be bootable.

6. Copy the AWDFLASH and BIOS files to the drive, and you should be good to go. You should even be able to use  AUTOEXEC.BAT if you want, but I prefer to do flashes manually.
0
 

Author Comment

by:samirst
ID: 20027084
This is what I have done and it worked perfectly.
1. Disconnected the Hard disk and CD ROM (as I had no access to BIOS)
2. formatted a floppy disk on another computer with the 'format as a dos disk' option
3. Formatted USB stick using FAT
4. installed HP USB Boot Disk on spare PC and created the A: drive image on USB stick from the floppy
5. Rebooted with the stick in faulty machine where it booted as an A: drive
6. Removed the USB while the A: prompt, deleted all files and copied the AWFLASH with the BIOS Bin file
7. Typed 'Run AWFLASH' after the A prompt and it worked like a dream.
You will not be able to add any additional files once the A: drive image is created regardless of the size of the USB, that is why I had to remove the stick, delete the boot files and add the AWDFLASH.

The closest answer to my solution above is coral47, so coral47 gets the full points.
Many thanks all.
0
 
LVL 32

Expert Comment

by:_
ID: 20029204
Thank you much.

>> ...and it worked perfectly

Nice.   : )

>> You will not be able to add any additional files once the A: drive image is created...

Thanks for the heads up.
I haven't used the HP utility yet, but it is suppose to make it easier to setup the flash drives to be bootable. Doesn't really sound like it helps that much.
Maybe for the 'first timers'.  ; )
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Monitor input from a computer is usually nothing special.  In this instance it prevented anyone from using the computer.  This was a preconfiguration that didn't work.
Microsoft will be releasing the Windows 10 Creators Update in just a matter of weeks. Are you prepared? Follow these steps to ensure everything goes smoothly and you don't lose valuable data on your PC.
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question