• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 9316
  • Last Modified:

Cannot Display .asp or .aspx pages in IIS6

Hi,

We are having problems getting IIS on Windows Server 2003 SP2 to display any asp or aspx pages.  The site will serve up html fine, but anything with an asp or aspx extension returns the following message in Internet Explorer:

Internet Explorer cannot display the webpage
   
   Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.
 
   What you can try:
     Check your Internet connection. Try visiting another website to make sure you are connected.  
 
     Retype the address.  
 
     Go back to the previous page.
 
     More information
This problem can be caused by a variety of issues, including:
Internet connectivity has been lost.
The website is temporarily unavailable.
The Domain Name Server (DNS) is not reachable.
The Domain Name Server (DNS) does not have a listing for the website's domain.
If this is an HTTPS (secure) address, click tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.


I have disabled friendly error messages in Internet Explorer and the IIS Debugging is set to show detailed asp errors, but this is all we get.

There is no issue with connectivity, as I can get the html pages and it is all running locally anyway.

The server is set to allow all Web Service Extensions (disabling the ASP or ASP.NET ones gives different page not found errors).

The Execute Permissions are set to "Scripts and Executables".

Is there anything else that should be enabled?  What else can we check to find the problem?  Let me know what other information would be useful.

Any help much appreciated.

Thanks in advance.
0
purplesoup
Asked:
purplesoup
1 Solution
 
ajarveyCommented:
Go into the properties of your website in IIS, and on the Home Directory tab click on the Configuration button towards the bottom. Check the path to the executable for .ASP and .ASPX pages and make sure that they are valid paths to your directory. I've seen all too many times where the extensions are set to something like C:\WINNT\System32\.... when the path to Windows is actually C:\WINDOWS\System32\...
0
 
thabolokoCommented:
try to remove IIS from Control Panel / Add and Remove Software / Add Windows Components. Restart and try to add again the IIS.

Also I would recommend to download .NET Framework 2.0, it would probably fix something wrong during the installation. I hope this helps, Gustavo.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now