Citrix Presentation Server Client will not display all on-screen data when used with Windows XP Embedded (XPe)

Posted on 2007-10-03
Last Modified: 2013-11-21
Calling all Experts!,

I have run into an interesting situation involving the use of Citrix Presentation Server Client 10.1 (web client) and an apparent incompatibility with Microsoft Windows XPe.

Here is some background:

Our company is using a third-party software for payroll that uses a Citrix Metaframe v.4 Server and hosts a payroll application that allows us to enter hours, tax info, etc. and it also allows us to view/print reports from within the program. This program works fine from any computer that is not a "thin-client", but it gets even more interesting! The program also works fine from within Terminal Services, as long as I am connecting to our Terminal Server (W2K3 Std.) via a computer that is also not a thin-client.

This is what happens:

As mentioned before, the payroll program being used via the Citrix web client allows for viewing and printing of reports, checks, stubs, etc. When I am using a non-thin-client computer, either using it's local desktop, or connecting via RDP to our terminal server, I can open the program, view reports and print them just fine. However, when I am using a thin-client, be it from it's local desktop, or via RDP, I CAN open the program, I CAN open the reports, that's when the fun stops, when a report opens no data shows up in it, it is just the report framework that shows (static elements such as Name, Date, etc., just with no accompanying information).

I have tried using this client with Administrative rights, and I have also upgraded to the latest client on the thin-client and the Terminal Server to see if it may help, but no luck. I have also made sure that when presented with the question "would you like for this application to have control over files on your computer" I always say "Full Control" and "Always" (I'm not sure if that's the exact text I am presented with).

Also, another interesting thing is this, when I connect using a regular PC (non-thin-client) and then disconnect, and reconnect using a thin-client to the same RDP session, I can then view the data, and if I close and re-open the application or disconnect and re-open the RDP session, it is still viewable. I am thinking there must be some sort of handshake when the RDP client initially logs in that determines whether it will work or not, but that is just a guess at this point.

Any help will be greatly appreciated!
Question by:Bill C. French
    LVL 15

    Expert Comment

    Have you tried uninstalling the web client and installing the Program Neighborhood client only?  Just a thought.  We have many thin clients in our enviroment (running XPe) that have no issues using apps through a web client, so I find it very hard to believe that this is an inherent issue with the ICA client or the XPe operating system.

    Another thing you may need to consider is that this is an issue with your application and its compatibility with the ICA protocol.  We use a suite of products from Thomson that has a similar issue that is only present when using the app from a station with a dual-screen setup.  We had to stay on the 8.1 client for a very long time while the provider worked with Citrix to determine the cause, we eventually were provided with a workaround that involved editing the default.ica file and putting specific config settings for each app that was affected by this issue.

    I know that is not much of a solution, but I hope it helps you to understand that A) you are not crazy and that these issues are somewhat "common" in Citrix environments and B) the answer may not lie with Citrix but with the provider of the software.

    What is the name of the application you are using - I may be able to dig up more if I know where to look.
    LVL 3

    Author Comment

    by:Bill C. French

    I appreciate your input on the matter, to answer your questions:

    Yes - I have tried uninstalling the web client and installing the program neighborhood client only, no success (just tried it after seeing your post)

    I understand that it may be an ICA protocol compatibility issue with the thin-client, however, I have tried it using another brand of thin client and I get the same issue, and unless they are using the same hardware/software setup (which they are not), the only conclusion that I can draw is that it has something to do with an incompatibility with XPe. The only type of thin-client I haven't tried using is a Linux-based one, which I don't have access to unfortunately.

    The point you made about the dual-display being incompatible is intersting, I am not using a dual-display thin-client, however, it would be interesting to find out after all of this is over if I have an incompatibility with the on-board video card on the thin-client. In the meantime, I will use a PCI video card in the available slot to test it that way and get back to you.

    Also, the name of the app is "Encore" and it is here:

    I can provide you with a demo logon/pw if you wish to test yourself.

    LVL 3

    Accepted Solution


    I figured out the problem, the built-in vga adapter for the Neoware Thin-client was the culprit. I added a second PCI VGA Video Card, specifically a cheap GeForce 5500 that I got for about 20$ at the store, it works fine now, no issues!

    Please refund the points and accept this as a solution.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    #Citrix #Citrix Policies #XenDesktop #VDI #POC #Citrix Univeral Printer Driver #Citrix UPD
    ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
    How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now