[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 258
  • Last Modified:

Cannot ping behind Cisco PIX 501

We have two PIX 501's set up at different sites.  They are both using VPN to connect to each other.  We cannot ping anything on the internet or on the VPN network, but can ping inside the LAN just fine.  We do have internet access out, and the VPN seems to be working correctly (we can access shared folders on remote computers) but we can't ping them.  Any ideas?  The configurations for both routers are posted below.  xxx.xxx.xxx.xxx is the external IP from the router "Ptown" and yyy.yyy.yyy.yyy is the external IP for router "Nhope."  Thanks


PTown config:
: Saved
: Written by enable_15 at 03:45:12.678 CST Wed Oct 3 2007
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 7XvWSM.CFJ0mFdkf encrypted
passwd 7XvWSM.CFJ0mFdkf encrypted
hostname PTown
domain-name domain.local
clock timezone CST -6
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.2.0 NHopeVPN
access-list outbound permit tcp 192.168.1.0 255.255.255.0 any
access-list outbound permit udp 192.168.1.0 255.255.255.0 any
access-list outbound permit icmp any any
access-list inbound permit tcp any any eq 3389
access-list inbound permit tcp any interface outside eq 3389
access-list inbound permit tcp any interface outside eq https
access-list inbound permit tcp any interface outside eq 3390
access-list inbound permit tcp any interface outside eq 5501
access-list inbound permit tcp any interface outside eq 5500
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 NHopeVPN 255.255.255.0
access-list outside_cryptomap_40 permit ip 192.168.1.0 255.255.255.0 NHopeVPN 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location xxx.xxx.xxx.xxx 255.255.255.255 outside
pdm location 192.168.1.0 255.255.255.255 inside
pdm location 192.168.1.2 255.255.255.255 inside
pdm location 192.168.1.100 255.255.255.255 inside
pdm location NHopeVPN 255.255.255.0 outside
pdm location 192.168.1.90 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3390 192.168.1.100 3390 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5901 192.168.1.2 5901 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.1.100 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5501 192.168.1.90 5501 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5500 192.168.1.90 5500 netmask 255.255.255.255 0 0
access-group inbound in interface outside
access-group outbound in interface inside
route outside NHopeVPN 255.255.255.0 192.168.2.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server 192.43.244.18 source inside
http server enable
http NHopeVPN 255.255.255.0 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address outside_cryptomap_40
crypto map outside_map 40 set peer yyy.yyy.yyy.yyy
crypto map outside_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ***** address yyy.yyy.yyy.yyy netmask 255.255.255.255 no-xauth no-config-mode
isakmp nat-traversal 60
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash sha
isakmp policy 40 group 1
isakmp policy 40 lifetime 86400
telnet 192.168.1.0 255.255.255.255 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:f303f82e1b14c7f197e73c5c35105693
: end




NHope config:

: Written by enable_15 at 13:34:04.468 CST Wed Oct 3 2007
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 7XvWSM.CFJ0mFdkf encrypted
passwd 7XvWSM.CFJ0mFdkf encrypted
hostname nhope
domain-name domain.local
clock timezone CST -6
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.0 PTownVPN
access-list outbound permit tcp 192.168.2.0 255.255.255.0 any
access-list outbound permit udp 192.168.2.0 255.255.255.0 any
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq smtp
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq 3389
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq https
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq 993
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq pop3
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq imap4
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq 995
access-list inbound permit icmp any any
access-list inbound permit tcp any host yyy.yyy.yyy.yyy eq 5501
access-list inbound permit tcp any interface outside eq 5500
access-list inside_nat0_outbound permit ip 192.168.2.0 255.255.255.0 PTownVPN 255.255.255.0
access-list inside_nat0_outbound permit icmp any any
access-list outside_cryptomap_40 permit ip 192.168.2.0 255.255.255.0 PTownVPN 255.255.255.0
access-list outside_cryptomap_40 permit icmp any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside yyy.yyy.yyy.yyy 255.255.255.248
ip address inside 192.168.2.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.2.100 255.255.255.255 inside
pdm location PTownVPN 255.255.255.0 outside
pdm location 192.168.1.90 255.255.255.255 inside
pdm location PTownVPN 255.255.255.0 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.2.100 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.2.100 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.2.100 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 993 192.168.2.100 993 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 192.168.2.100 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface imap4 192.168.2.100 imap4 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 995 192.168.2.100 995 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5500 192.168.1.90 5500 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5501 192.168.1.90 5501 netmask 255.255.255.255 0 0
access-group inbound in interface outside
access-group outbound in interface inside
route outside 0.0.0.0 0.0.0.0 74.94.82.30 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server 192.43.244.18 source outside prefer
http server enable
http PTownVPN 255.255.255.0 outside
http 192.168.2.0 255.255.255.0 inside
http PTownVPN 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address outside_cryptomap_40
crypto map outside_map 40 set peer xxx.xxx.xxx.xxx
crypto map outside_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address xxx.xxx.xxx.xxx netmask 255.255.255.255 no-xauth no-config-mode
isakmp keepalive 60 30
isakmp nat-traversal 60
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash sha
isakmp policy 40 group 1
isakmp policy 40 lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:7fe3f26f4c2dc2a911a0acc709fb1cdb
: end

0
OAC Technology
Asked:
OAC Technology
1 Solution
 
poweruser32Commented:
so if you are on one of the 2 lans you cannot access the internet?if you do a tracert to google what does it show?
0
 
lrmooreCommented:
>access-group outbound in interface inside
Remove the acl from the inside interface on both ends.

Add to both ends:
  isakmp identity address

On PTown, add:
  access-list inbound permit icmp any any

>isakmp policy 40 group 1  <== this should be group 2 on both ends

On NHope, remove this, or add it to PTown to match.
  > isakmp keepalive 60 30

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now