MySQL Install on Windows won't accept remote host connections

Everything works great from the localhost, but remote connections get an error like "MySQL Connection is not allowed from host, YOURHOST"

Obviously I'm missing a config of some sort, this is a fresh install of 5.0.45 on Windows Server 2003 32-bit.

Thanks for any help with what I need to do/add/configure/etc
Who is Participating?
Aleksandar BradarićSoftware DeveloperCommented:
You have to use the GRANT command to allow access from other servers, like:
GRANT ALL ON yourDatabase.yourTable TO yourUser@yourHost IDENTIFIED BY 'yourPassword';

See more here:
My suggest stems from Linux, but I believe Windows might have something similar going on. Latest version of MySQL at least will by default bind itself to "localhost" (loopback interface) instead of "" (all available interfaces) as a security measure. This setting can be changed from within my.cnf (my.ini, whatever:) with setting "bind-address" (which is under section "mysqld").
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.