jokes54321
asked on
OSPF, NAT, and Null Interface
We acquired a site that happens to have an overlapping subnet. I configured the router to NAT the subnet to another subnet. We also use OSPF over Sprint MPLS for routing updates. I am having trouble getting this router to annouce this NATTED subnet.
Any suggestions??
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.20.174.198 255.255.255.252
ip nat outside
service-module t1 timeslots 1-4
!
router ospf 1
router-id 172.20.174.198
log-adjacency-changes
redistribute static subnets
passive-interface FastEthernet0/0
network 172.20.174.196 0.0.0.3 area 0
network 192.168.41.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 192.168.41.0 255.255.255.0 Null0
ip route 192.168.200.0 255.255.255.0 192.168.1.1
!
ip nat inside source static network 192.168.1.0 192.168.41.0 /24
!
Any suggestions??
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.20.174.198 255.255.255.252
ip nat outside
service-module t1 timeslots 1-4
!
router ospf 1
router-id 172.20.174.198
log-adjacency-changes
redistribute static subnets
passive-interface FastEthernet0/0
network 172.20.174.196 0.0.0.3 area 0
network 192.168.41.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 192.168.41.0 255.255.255.0 Null0
ip route 192.168.200.0 255.255.255.0 192.168.1.1
!
ip nat inside source static network 192.168.1.0 192.168.41.0 /24
!
ASKER
I found a workaround but I am not sure why it didn't work the other way.
I added a loopback1 interface with the address 192.168.41.1 255.255.255.0 and now the subnet is being distributed via OSPF.
I added a loopback1 interface with the address 192.168.41.1 255.255.255.0 and now the subnet is being distributed via OSPF.
ASKER CERTIFIED SOLUTION
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
ASKER
For a quick test I added network 192.168.1.0 0.0.0.255 area 0 to the router ospf 1 section and the route was properly distributed to our other routers.