Switch supports only 1 connection w/Comcast internet connection.

I have high-speed internet with Comcast - an Arris modem, model TM502G with a single ethernet port.  I've hooked it up to two different Cisco switches as well as a LinkSys workgroup switch.  I've connected several computers to the switches.  My problem is that no more than one computer at a time can acquire an internet connection.  Right now, for example, I have two PCs and a laptop connected to my switch.  Only my PC has an internet connection.  On my other PC and laptop I get the following error message from the "ipconfig /renew" command:

"An error occurred while renewing interface Local Area Connection : unable to contact your DHCP server. Request has timed out."

The "ipconfig" command gives me an address of  

When I disconnect my PC, neither of the other computers pick up a connection automatically, but when I reset the modem, one, but not the other, computer becomes the computer that gets the IP address.  The other computer continues to get the error.  

Normally I get a public address from Comcast when I connect to the internet; something in the range of 71.x.x.x to 76.x.x.x.  But when I disconnected all the PCs except for one and then reset the modem I got an IP addres of 192.X.x.x - a private address.  Then when I connected a second PC I got a public address!  73.x.x.x.  And what's more, even with this address I couldn't connect to the internet!   Then I went back to the original computer - the one that had the 192 address - and the address had changed to 71.x.x.x and I still have connectivity.  This is just nuts.  Other info:  The subnet mask is always  The DNS Suffix Search List is "hsd1.ma.comcast.net".  

Comcast tech support assures me that they are not doing anything to prevent the use of switches, but they also offer a modem with four ethernet jacks for an extra $150.00.  By the way, when I had DSL I couls attach the modem to a switch with no problems.  Can anyone tell me what I can do to be able to add more computers to my switches?  
Who is Participating?
tedsiniAuthor Commented:
Never mind, I figured out how to run dhcp on my switch, which was my only option given the equipment that I currently own.  For someone else having this problem, here is what I did:

Both the cable companies like Comcast and the DSL companies like Verizon give you an address that can be split using private addresses - network address translation works on the same principal.  The problem is that someone has to provide a dhcp server.  Normally, the service provider does this.  But if they don't, then you have to do it yourself.   I don't own a router, but I wanted someone to tell me how to do this with a switch.  As it turns out, you use the "ip helper-address" command.  The link below provides a good explanation.  Thanks anyway.

Don JohnstonInstructorCommented:
My Comcast account (and many other people that I know with home accounts) are only allowed a single IP address.  If you're willing to pay extra, you can get a static IP address and buy paying even more, you may be able to get multiple IP addresses.
You better have a router that will help.
To explain further - a switch only splits an exiting network cable into multiple ports - kinda like an extension cord with multiple plugins on the end - each plug gets the same 'power' that every other plug gets.

What you need is a router - a router will create a network for all of your home pcs - giving them each their own IP address (typicall 192.168.1.???) - the router gets the one external IP address from the cable modem and 'routes' all requests for internet access from each PC to the modem and back.

You can pick up a Linksys wirless-G modem that will also give you wireless for about $50 about anywhere.

A switch will not work.

Good Luck.

Closed, 250 points refunded.
Community Support Moderator
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.