?
Solved

Fedora Core 6 Cannot start up the system with error: An error occurred during file system check

Posted on 2007-10-04
7
Medium Priority
?
359 Views
Last Modified: 2013-12-16
I am using Fedora Core 6. I have the following error during booting up the system.
Checking filesystems
fsck.ext3: Is a directory while trying to open /home/a
fsck.ext3: Is a directory while trying to open /home/b
fsck.ext3: Is a directory while trying to open /home/c
fsck.ext3: Is a directory while trying to open /home/d
fsck.ext3: Is a directory while trying to open /home/e
                                                                                       [FAILED]
*** An error occurred during file system check.
*** Dropping you to a shell; the system will reboot
*** when you leave the shell.
Give root password for maintenance
(or type Control-D to continue):

I know that something is wrong in /etc/fstab which makes the system cannot start up. I try to edit /etc/fstab, however, linux says the file system is read-only. Do you know how to fix this problem?
0
Comment
Question by:godman_polly
  • 3
  • 3
7 Comments
 
LVL 19

Expert Comment

by:http:// thevpn.guru
ID: 20012378
it is not fstab..a filesystem on your hardisk is corrupt..enter your root password and then do fsck -A I guess that should do it
0
 

Author Comment

by:godman_polly
ID: 20012402
no. the position of the device and the mount point in /etc/fstab is swapped. is there any way to edit /etc/fstab?
0
 
LVL 6

Expert Comment

by:psyclown-
ID: 20012407
I think you need to run fsck on the drive:

Take a look at this link (the first comment):
https://www.centos.org/modules/newbb/viewtopic.php?forum=14&topic_id=78&viewmode=flat
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 19

Accepted Solution

by:
http:// thevpn.guru earned 375 total points
ID: 20012420
If you insist on editing fstab..you can enter a live cd boot the system and edit it from there or try sudo vi /etc/fstab
0
 

Author Comment

by:godman_polly
ID: 20012574
I use the installer to boot up the system and enter the resue mode. However, /etc/fstab is missing. Besides, I cannot use sudo. The file system again is read-only.
0
 
LVL 19

Expert Comment

by:http:// thevpn.guru
ID: 20012594
did you try the fsck  ?
0
 

Author Comment

by:godman_polly
ID: 20012664
I find the fstab is in /mnt/systemimage/etc/fstab. I edit it and fix the problem.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month16 days, 14 hours left to enroll

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question