We help IT Professionals succeed at work.

Cisco Pix 501 VPN not working after changing ISP

377 Views
Last Modified: 2010-04-09
Hi All

I have a problem with a Cisco Pix 501.

My customer has changed ISP's and i have reconfigured the Pix to use the new ip addresses etc, all the inbound rules appear to be working for SMTP etc but VPN isn't.

I don't really know the pix too well so was hoping someone could see the problem.

Running conf below, i have substitued their new IP addresses for xx.xx.xx.000 for security reasons!

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8xJq2mfzyA3HxUc/ encrypted
passwd N7FecZuSHJlVZC2P encrypted
hostname PIX-501-01
domain-name pix.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group service inboundallowedTCP tcp
  port-object eq www
  port-object range 3389 3389
  port-object eq domain
  port-object eq https
  port-object eq smtp
access-list 101 permit tcp any host 217.154.2.194 object-group inboundallowedTCP  <-entries for old ip addresses can't seem to remove!
access-list 101 permit tcp any host 217.154.2.194 eq www  <-entries for old ip addresses can't seem to remove!
access-list 101 permit tcp any host 217.154.2.194 eq https  <-entries for old ip addresses can't seem to remove!
access-list 101 permit icmp any any echo-reply
access-list 101 permit tcp any host 217.154.2.194 eq smtp  <-entries for old ip addresses can't seem to remove!
access-list 101 permit tcp any host XXX.XXX.XXX.121 object-group inboundallowedTCP
access-list 101 permit tcp any host XXX.XXX.XXX.122 object-group inboundallowedTCP
access-list 101 permit tcp any host XXX.XXX.XXX.122 eq www
access-list 101 permit tcp any host XXX.XXX.XXX.122 eq https
access-list 101 permit tcp any host XXX.XXX.XXX.122 eq smtp
access-list inbound permit tcp any interface outside eq https
access-list inbound permit tcp any interface outside eq smtp
access-list inbound permit tcp any interface outside eq www
access-list inbound permit tcp any interface outside eq domain
access-list inbound permit tcp any interface outside eq 3389
access-list inbound permit tcp any interface outside eq 3390
access-list inside_outbound_nat0_acl permit ip 192.168.111.0 255.255.255.0 10.0.0.0 255.255.255.0
access-list Radius_splitTunnelAcl permit ip 192.168.111.0 255.255.255.0 any
access-list RemoteVPN_splitTunnelAcl permit ip 192.168.111.0 255.255.255.0 any
access-list outside_cryptomap_dyn_40 permit ip any 10.0.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside XXX.XXX.XXX.122 255.255.255.252
ip address inside 192.168.111.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool RemotePool 10.0.0.100-10.0.0.200
pdm location 192.168.111.2 255.255.255.255 inside
pdm location 192.168.111.3 255.255.255.255 inside
pdm location 194.168.83.233 255.255.255.255 outside
pdm location 194.164.83.233 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.111.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.111.2 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.111.2 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface domain 192.168.111.2 domain netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.111.3 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3390 192.168.111.2 3390 netmask 255.255.255.255 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 XXX.XXX.XXX.121 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server WindowsIAS protocol radius
aaa-server WindowsIAS max-failed-attempts 3
aaa-server WindowsIAS deadtime 10
aaa-server WindowsIAS (inside) host 192.168.111.2 pineapple timeout 5
http server enable
http 192.168.111.0 255.255.255.0 inside
http 192.168.111.2 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
auth-prompt prompt Authenticating Through AAA
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash sha
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
vpngroup RemoteVPN address-pool RemotePool
vpngroup RemoteVPN dns-server 192.168.111.2
vpngroup RemoteVPN wins-server 192.168.111.2
vpngroup RemoteVPN default-domain omni.local
vpngroup RemoteVPN split-tunnel RemoteVPN_splitTunnelAcl
vpngroup RemoteVPN idle-time 1800
vpngroup RemoteVPN password ********
vpngroup Radius address-pool RemotePool
vpngroup Radius dns-server 192.168.111.2
vpngroup Radius wins-server 192.168.111.2
vpngroup Radius default-domain omni.local
vpngroup Radius split-tunnel Radius_splitTunnelAcl
vpngroup Radius idle-time 1800
vpngroup Radius secure-unit-authentication
vpngroup Radius authentication-server WindowsIAS
vpngroup Radius user-authentication
vpngroup Radius user-idle-timeout 30
vpngroup Radius device-pass-through
vpngroup Radius password ********
telnet timeout 5
ssh 194.164.83.233 255.255.255.255 outside
ssh 192.168.111.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd address 192.168.111.2-192.168.111.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username fusion password BOJBOUzDoUsGY.fc encrypted privilege 15
terminal width 80
Cryptochecksum:741ccf93a68901dbe12c918f884b4695
: end
[OK]



Regards

Justin
Comment
Watch Question

CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Les MooreSystems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Have tried a reboot, but that doesn't appear to have made any difference.

There is one other thing that has changed, the firebox was connected to the internet via a Speed Touch which was knocking on a bit, so that was replaced with a Zyxel, which had firewall and nat disabled on it (this is the configuration used with Watchguard fireboxes).

Is anyone aware of any issues with Zyxel's?

Also how to i remove the old access-list entries?

CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
This is the log from the Cisco VPN client, does this shed any light on the problem?

1     09:51:19.445  10/05/07  Sev=Warning/3       IKE/0xE3000056
The received HASH payload cannot be verified
 
2     09:51:19.445  10/05/07  Sev=Warning/2       IKE/0xE300007D
Hash verification failed... may be configured with invalid group password.
 
3     09:51:19.445  10/05/07  Sev=Warning/2       IKE/0xE3000099
Failed to authenticate peer (Navigator:904)
 
4     09:51:19.445  10/05/07  Sev=Warning/2       IKE/0xE30000A5
Unexpected SW error occurred while processing Aggressive Mode negotiator:(Navigator:2202)

CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.