[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

execute sp_addlinkedserver to add the server to sysservers

Posted on 2007-10-04
4
Medium Priority
?
4,662 Views
Last Modified: 2008-01-09
Hi experts

I have SQL 2000 SP4

i want to export the customers table in CSV
i followed the export wizard
i selected the source
i select the destination
when i click next i get the follwoing error:

Error Source : Mircosoft OLE DB Provider for SQL Server
Error Description : unspecified error
Could not find v8-pat in sysservers. execute sp_addlinkedserver to add the server to sysservers

context : Error calling getrowSet to get DBSHEMA_TABLES schema info.
Your provider does not support all the schema rowset required by DTS

Please note that my server name is not v8-pat !
please help
0
Comment
Question by:humer2000
  • 2
  • 2
4 Comments
 
LVL 8

Accepted Solution

by:
Bradley Haynes earned 2000 total points
ID: 20018773
Are you using EM to run the DTS? If so, have you register the servers, Source and
destination? It should be all you need. When you register the server you will need a valid
user id with SQL Server administration rights (could use sa, but for security
reasons you should have an account to run this DTS jobs) so the DTS package will run without
any problems.
There is a problem with DTS in SQL Server 2000 Service
Pack 2. Databases with dots in the names will generate the errors you are seeing.
Rename the destination database so the name does not contain a dot.
0
 
LVL 1

Author Comment

by:humer2000
ID: 20019931
hi i followed your instructions and still not working
i have same error message
yes i m using EM with sa account
the problem is that my server name is nemesis-26 and in the error message i am getting
Could not find v8-pat in sysservers. execute sp_addlinkedserver to add the server to sysservers
v8-pat is not the server name, not even a db name !
0
 
LVL 1

Author Comment

by:humer2000
ID: 20019942
ahh i have noticed something in accordance with what u said
the db name is v8-pat.com

do u thing the problem is in the DOT with the db name ?
0
 
LVL 8

Expert Comment

by:Bradley Haynes
ID: 20022790
Yes the DOT is a problem. The DOT notation indicates the default db in MySQL, i know special characters are not allowed in SQL Server 2000 db names i.e \,@, and the like.

Here is a link to a document that covers naming conventions.
http://72.14.253.104/search?q=cache:8KuZeftIxgIJ:www.cms.hhs.gov/DBAdmin/downloads/SQLServerStandardsandGuildelines.pdf+sql+2000+naming+rules&hl=en&ct=clnk&cd=3&gl=us

0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows gives you an overview on SQL Server 2016 row level security. You will also get to know the usages of row-level-security and how it works
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Familiarize people with the process of utilizing SQL Server functions from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Ac…
Using examples as well as descriptions, and references to Books Online, show the different Recovery Models available in SQL Server and explain, as well as show how full, differential and transaction log backups are performed
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question