Sharepoint Does not work. The page cannot be found.

I did a fresh install of Windows 2003 SBS R2 on a supermicro server.  Everything appeared to install with no errors.  Once the install was done I ran SP2 and all other critical updates.  I did not try to access http://companyweb or open Sharepoint Central Administration prior to doing the updates so I do not know if they worked prior to running SP2.  When I start windows explorer I get that page cannot be displayed and when I run Sharepoint Central Administration I get the same error.  I can ping companyweb the home directory is c:\inetpub\companyweb the IIS website is running the services for sharepoint and sql are running.  I believe I need to remove and reinstall Sharepoint as stated in this URL How to remove and how to install the Windows Small Business Server 2003 SharePoint Services companyweb Web site but will it work since I have the R2 disks but I have put SP2 on the Server and it had SP1 from the original install?  Thanks for the help.
pcsonwheelsAsked:
Who is Participating?
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Don't reinstall IIS... that's about the worst thing you can do.  It should only be done in a last ditch effort situation.

The recommended fix here is to reinstall Windows SharePoint Services SP2.  Please review the Release Notes for SBS R2:  http://www.microsoft.com/technet/prodtechnol/sbs/2003/support/documentation/f9fc9953-d0d7-4990-a189-a12bf8602917.mspx?mfr=true

Jeff
TechSoEasy
0
 
Olaf De CeusterCommented:
IN IIS: Websites> Default website> Properties> ASP.Net Tab> Set your ASP.Net version to 1.1.something as opposed to version 2.
At Command prompt: iisreset.
Try again.
Let me know if that didn't work.
Olaf
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
"Once the install was done I ran SP2 and all other critical updates."

Did you install the updates BEFORE or AFTER doing everything on the To-Do list?  Because those steps should have all been completed BEFORE you installed any updates.  This is because the scripts invoked by the SBS Wizards were all created before any of those updates.

Also, it's recommended that you do not install Windows Server 2003 SP2 before installing the R2 components.

If you are getting those kind of errors though, I wouldn't actually do a remove and reinstall of SharePoint... you are too close to the initial install to be trying to patch things up... start over and reinstall again.

FYI, it's generally accepted that it takes at least 3 times to install your first SBS:  http://sbsurl.com/3x

:-)

Jeff
TechSoEasy
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
pcsonwheelsAuthor Commented:
I tried changing asp.net to v1.1  then ran iisreset but te same problem still exists.  
0
 
Olaf De CeusterCommented:
Reinstall IIS.
0
 
pcsonwheelsAuthor Commented:
I ran the to do list before updating to SP2.
0
 
pcsonwheelsAuthor Commented:
Will SP2 need to be reinstalled after I uninstall IIS and Install IIS?
0
 
Olaf De CeusterCommented:
No SP2 till you are happy with everything.
Olaf
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.