[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 440
  • Last Modified:

Cisco PIX 501 port forward question...

Hi,
This is a fairly simple and straight-forward task to perform but I am having a heck of a time here with this.
We have a customer who wants to be able to access his DVR system from the internet. I have added the access lists and forwarded the correct ports but cannot seem to get this working from the outside. Internally, I can open a web browser, put in the private address and the DVR system comes up fine. I have gone through this config line by line against other configs I have and they are identical. Is there something I am missing here?

IS31# config t
IS31(config)# wr t
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ********* encrypted
passwd ************* encrypted
hostname IS31
domain-name Verizon.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
no names
name 192.168.31.51 REG1
name 192.168.31.52 REG2
name 192.168.31.53 REG3
name 192.168.31.54 REG4
name 192.168.31.55 REG5
name 192.168.31.56 REG6
name 192.168.31.57 REG7
name 192.168.31.58 REG8
name 192.168.31.59 REG9
name 192.168.31.60 REG10
name 192.168.31.61 REG11
name 192.168.31.62 REG12
name 192.168.31.71 BO1
name 192.168.31.72 BO2
name *********** NIT_Outside
name 192.168.31.20 WAP1
name ************* ISHQ
name 192.168.31.10 DVR
name 192.168.31.50 TV
access-list NONAT_IN permit ip 192.168.31.0 255.255.255.0 172.32.10.0 255.255.255.0
access-list NONAT_IN permit ip 192.168.31.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list IS31_NIT permit ip 192.168.31.0 255.255.255.0 172.32.10.0 255.255.255.0
access-list acl_out permit tcp any any eq 3389
access-list acl_out permit tcp any any eq 5900
access-list acl_out permit udp any any eq 5900
access-list acl_out permit udp any any eq 3389
access-list acl_out permit tcp any any eq www
access-list acl_out permit udp any any eq www
access-list IS31_HQ permit ip 192.168.31.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside ******** 255.255.255.0
ip address inside 192.168.31.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT_IN
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 192.168.31.5 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5900 192.168.31.5 5900 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 5900 192.168.31.5 5900 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.31.10 www netmask 255.255.255.255 0 0
static (inside,outside) udp interface www 192.168.31.10 www netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 ********** 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strongdes esp-3des esp-sha-hmac
crypto map toNIT 31 ipsec-isakmp
crypto map toNIT 31 match address IS31_HQ
crypto map toNIT 31 set peer **************
crypto map toNIT 31 set transform-set strongdes
crypto map toNIT 81 ipsec-isakmp
crypto map toNIT 81 match address IS31_NIT
crypto map toNIT 81 set peer *************
crypto map toNIT 81 set transform-set strongdes
crypto map toNIT interface outside
isakmp enable outside
isakmp key ******** address *********** netmask 255.255.255.255
isakmp key ******** address *********** netmask 255.255.255.255
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 0.0.0.0 0.0.0.0 outside
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
management-access inside
console timeout 0
dhcpd address 192.168.31.100-192.168.31.149 inside
dhcpd dns 66.28.0.45 66.28.0.61
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
Cryptochecksum:4ba206b2ea0df7560db2ff7149c11522
: end
[OK]
IS31(config)#
0
networkinfotech
Asked:
networkinfotech
  • 13
  • 9
  • 4
1 Solution
 
grbladesCommented:
Try issuing the command 'clear xlate' to rebuild the translation table in memory to see if that works.

If it doesn't then it may be to do with the PIX itself listening on port 80 for its webserver used for configuration. You could try disabling that.
You appear to have a few external IP addresses that you can use judging by your subnet mask. It may be better to use an alternative IP address if you can.
0
 
networkinfotechAuthor Commented:
Yeah, I tried the clear xlate and also bouncing the PIX. Didn't fix the issue. The translation is correct and the access lists are getting hits. I just dont get it. Weird.
As for the extra addresses, unfortunately the client wants everything to come in through the same port.

-Pete
0
 
grbladesCommented:
I assume you meant the client want the same IP address to be used externally?
Do you actually use UDP port 80?

How about trying this and accessing using htp://xxx.xxx.xxx.xxx:81/
static (inside,outside) tcp interface 81 192.168.31.10 www netmask 255.255.255.255 0 0
access-list acl_out permit tcp any any eq 81
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
networkinfotechAuthor Commented:
Just tried that. No go. I also removed every other line in there that didnt belong. Interestingly enough, I could ping 192.168.31.10 from the inside interface on the PIX.
-Pete
0
 
networkinfotechAuthor Commented:
Also, I have a VPN tunnel from here (172.32.10.x)  to there (192.168.31.x) and I cannot access the DVR system with the private IP address in a browser. I can however access pcA to the other PC's. From the local PC (192.168.31.51), I can see it in the browser.

Also, I cannot ping the DVR from here (172.32.10.x network) but can ping it locally. I can however ping all the other PC's at that site from here.
0
 
grbladesCommented:
Perhaps its a configuration issue on the DVR. Check the subnet mask and default gateway is set correctly.
0
 
networkinfotechAuthor Commented:
I just cleared the access lists and cleaned out everything else. I recreated the access lists (now as outside_access_in instead of acl_out). Still doesn't work.
If there was an issue with the subnet and gateway, would the tunnels still work?
Here is what the sh xlate command shows now.
PAT Global x.x.x.x(80) Local 192.168.31.10(80)

Here is the "revised config":
IS31(config)# wr t
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ******* encrypted
passwd ******* encrypted
hostname IS31
domain-name Verizon.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
no names
name 192.168.31.51 REG1
name 192.168.31.52 REG2
name 192.168.31.53 REG3
name 192.168.31.54 REG4
name 192.168.31.55 REG5
name 192.168.31.56 REG6
name 192.168.31.57 REG7
name 192.168.31.58 REG8
name 192.168.31.59 REG9
name 192.168.31.60 REG10
name 192.168.31.61 REG11
name 192.168.31.62 REG12
name 192.168.31.71 BO1
name 192.168.31.72 BO2
name ************ NIT_Outside
name 192.168.31.20 WAP1
name 165.254.178.162 ISHQ
name 192.168.31.10 DVR
name 192.168.31.50 TV
access-list NONAT_IN permit ip 192.168.31.0 255.255.255.0 172.32.10.0 255.255.255.0
access-list NONAT_IN permit ip 192.168.31.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list IS31_NIT permit ip 192.168.31.0 255.255.255.0 172.32.10.0 255.255.255.0
access-list outside_access_in permit tcp any any eq www
access-list IS31_HQ permit ip 192.168.31.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 71.249.166.81 255.255.255.0
ip address inside 192.168.31.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT_IN
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www 192.168.31.10 www netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 ************** 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strongdes esp-3des esp-sha-hmac
crypto map toNIT 31 ipsec-isakmp
crypto map toNIT 31 match address IS31_HQ
crypto map toNIT 31 set peer x.x.x.x
crypto map toNIT 31 set transform-set strongdes
crypto map toNIT 81 ipsec-isakmp
crypto map toNIT 81 match address IS31_NIT
crypto map toNIT 81 set peer x.x.x.x
crypto map toNIT 81 set transform-set strongdes
crypto map toNIT interface outside
isakmp enable outside
isakmp key ******** address x.x.x.x netmask 255.255.255.255
isakmp key ******** address x.x.x.x netmask 255.255.255.255
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 0.0.0.0 0.0.0.0 outside
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
management-access inside
console timeout 0
dhcpd address 192.168.31.100-192.168.31.149 inside
dhcpd dns 66.28.0.45 66.28.0.61
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80
Cryptochecksum:cb3e0cb02bf218fcbbc7bf7e0f646aa7
: end
[OK]
IS31(config)#

-Pete
0
 
grbladesCommented:
Did you check the network configuration of the DVR itself. Thats what I was refering to.
The fact that you could not access it over the VPN also points to a configuration issue on the DVR stopping it from being able to communicate with anything outside of its own local lan.
0
 
Alan Huseyin KayahanCommented:
  Do you reach DVR via http:// or https:// ?
   As I understood so far, you type http://pixoutsideipaddress to web browser in a computer connected to internet and you want the DVR web interface. Then the question is,
      *What happens when you Start>Run>Cmd then   telnet pixoutsideipaddress 80    .Does that command bring a blank screen or it fails to connect?
      *Best way of tracking down a prblem ina an IOS device is monitoring syslogs. What logs fall to syslog when you hit enter in browser to reach the page?

Regards
0
 
networkinfotechAuthor Commented:
Times out on a telnet session. Both the internal and external addresses. DVR should be reached by http (80).
Sadly, I dont have much experience in syslogs so I wouldnt be much help with that (unless someone wants to give me a 5 minute crash course (poor choice of words) in syslogs.
-Pete
0
 
grbladesCommented:
Was the DVR network config correct?
0
 
networkinfotechAuthor Commented:
Yes. I can log ito a PC via pcA and open a browser and see the DVR login when I access it locally (http://192.168.31.10)

0
 
grbladesCommented:
Yes but is the DVR configured with the correct subnet mask and default gateway.

If its not then it will work fine locally but not remotely which is exactly the problem you are having.
0
 
networkinfotechAuthor Commented:
Yeah, everything is correct on it. 192.168.31.1 is the gateway. Subnet is set to 255.255.255.0

-Pete
0
 
grbladesCommented:
Do you have a machine with a web server on it?
If its a server you should be able to add an additional IP address to the config. I would unplug the DVR and configure the webserver to respond on that IP address and then see if it works.
0
 
networkinfotechAuthor Commented:
Ok, I just opened 5900 for vnc on a PC that I know is running it. I cannot hit it via the tunnel or the public address. I can however vnc to it from a different PC on the network.
Any thoughts?
-Pete
0
 
networkinfotechAuthor Commented:
It seems as if this is a global outside interface issue because no port forwards are working at all.
0
 
grbladesCommented:
I cant see any config on the pix which would be causing this.
Could there be a firewall on the router infront of the PIX?
Is it easy for you to configure a machine and plug it into the internet inplace of the pix and seeing if you can connect to vnc etc... on it?

When you test for remote connectivity where are you connecting from?
0
 
networkinfotechAuthor Commented:
Not really a possibility to take the entire store down for that....at least when I am not there. This is a retail store and they have 12 registers running at all times.
I will most likely go on-site next week sometime to see what is happening.
When I connect, I am connecting via pcA to a PC there using the private (192.168.31.x) ip. From there, I fire up a web browser and go to 192.168.31.10 and I get the login page for the DVR system.
The reason I am pretty confident that this is a PIX issue is because none of the port forwarding is working at all. The VPN tunnels from there to my office are up fine. I can do an IP scan and see all of the devices in the 192.168.31.x range from my computer in the office. I am on 172.32.10.x range.
-Pete
0
 
grbladesCommented:
You can access the DVR ok from across the VPN?

Did you issue the 'clear xlate' command again after creating a static entry for vnc?


As the VPN is oviously working I would expect the DVR to work across the VPN. If it doesn't then I would expect there is a software bug in the DVR.

If you cant get any forwarding to work on the PIX then I would take along a small hub (or a managed switch you can mirror the ports on) and a machine containing a copy of ethereal and capture the traffic which is sent to the PIX to see if the the traffic is actually getting to it. It might have been blocked by a router upstream with only VPN allowed.
0
 
networkinfotechAuthor Commented:
Ok I will check this out most likely Monday or Tuesday. Thanks for all your help everyone.

-Pete
0
 
Alan Huseyin KayahanCommented:
   Hi networkinfotech
         If telnet does not work, forwarding means not OK.
         Would you please remove
        access-list outside_access_in permit tcp any any eq www
         then add
        access-list outside_access_in permit tcp any interface outside eq www

Regards
0
 
Alan Huseyin KayahanCommented:
 Would you please enter www.whatsmyip.com in 192.168.31.10 and verify if you see IP 71.249.166.81
0
 
networkinfotechAuthor Commented:
Ok, it does show the correct IP. Also, the access list switch didnt work.
I guess I will have the owner call the ISP and make sure ports arent filtered. It is Ver1zon so who knows.
Thanks guys (and possibly gals)....
-P
0
 
Alan Huseyin KayahanCommented:
    It is a weak possibilty that the ports are being filtered. It is obvious that, something wrong with your modem or router which dials Ver1zon, attached to outside interface of ASA. Bridging configuration may be missing/corrupt. I arrived at that conclusion because
     telnet 0.0.0.0 0.0.0.0 outside
     according to line above, I should be able to telnet your ASA, and I couldnt. Telnet has nothing to do with NATs ACLs and etc, so it is not ASA related.
     Btw, doublecheck if the below ip address/subnet mask assignment from Ver1zon is correct
     71.249.166.81 255.255.255.0
0
 
networkinfotechAuthor Commented:
Turns out, it was an issue with the DVR itself. Thanks everyone for all your help!

-P
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

  • 13
  • 9
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now