Qos Cisco 2950/Voip

Posted on 2007-10-05
Last Modified: 2009-01-11

I would like to utilize QOS with my Voice IP phones in my branch offices. Currently, I am using cisco 2950 switches, and would also like to set some bandwith limits on my switches as well to make sure there is enough capacity for the VIOP traffic...

Both branches has less than 20 pc's in each facility...I am very familiar with the cisco switch, but new to the QOS/VOIP..
Question by:Atomicsteaks
    LVL 12

    Expert Comment

    Here is my canned IOS QOS config.  It's from a router config, but I think it should still work for a switch.  This is for Cisco CallManager.

    class-map match-all VOIP-Control
      match access-group 101
    class-map match-all VOIP-RTP
      match access-group 100
    policy-map QOS-to-T1
      class VOIP-RTP
       priority 600
      class VOIP-Control
       bandwidth 200
      class class-default
    ! IIRC This policy map is to retag data after going over a link that was not guaranteed to maintain cos/tos bits.
    policy-map L3-to-L2-VOIP
      class VOIP-RTP
       set cos 5
      class VOIP-Control
       set cos 3
    interface FastEthernet0/0
     no ip address
     no ip mroute-cache
     speed auto
     no cdp enable
    interface FastEthernet0/0.1
     description Data_Subnet
     encapsulation dot1Q 1 native
     ip address
    interface FastEthernet0/0.2
     description Voice_Subnet
     encapsulation dot1Q 2
     ip address 192.168.x.1
     service-policy output L3-to-L2-VOIP
     no ip mroute-cache
    interface Serial0/0
     description HDSL T1
     ip unnumbered FastEthernet0/0.1
     service-policy output QOS-to-T1
     no ip mroute-cache
     no shutdown
     no cdp enable
    access-list 100 permit ip any any precedence critical
    access-list 100 permit ip any any dscp ef
    access-list 101 permit tcp any any range 2000 2002
    access-list 101 permit tcp any any eq 1720
    access-list 101 permit tcp any any range 11000 11999
    access-list 101 permit udp any any eq 2427
    access-list 101 permit tcp any any eq 2428

    LVL 10

    Accepted Solution

    Unfortunately, configuring qos on a switch works quite differently. However, you can use cisco auto qos to configure this, and it is pretty straightforward.

    For all access interfaces (connecting to phones):-

    auto qos voip cisco-phone

    For all trunk / uplink interfaces, and interfaces connecting to voip servers:-

    auto qos voip trust

    This will configure everything you need to prioritise voice on the switch. However, bear in mind that for qos to be effective, it needs to be configured on all network devices in your network.

    Note: This will only work correctly with Cisco IP Phones

    Article on autoqos:

    Featured Post

    Find Ransomware Secrets With All-Source Analysis

    Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

    Join & Write a Comment

    Suggested Solutions

    I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
    Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now