Error starting Windows SharePoint Server 3 Search

Posted on 2007-10-05
Last Modified: 2009-07-29
I am trying to start a new instance of a Microsoft Office SharePoint 2007 Server, and am having problems starting the Windows SharePoint Server Search service.
Here are the details:

The initial setup was performed by another administrator.  Because it did not have the naming/port conventions of our other SharePoint instances, it was decided we would clear out that setup and start a new one that did.  This was done by disconnecting from the server farm (this is the only server in the farm) and creating a new farm.  I am unsure whether or not the search service ever worked to begin with, as I didn't check before I unprovisoned.
When I tried to start the Windows SharePoint Search service, an IIS Application Error occured at the "Operation In Progress" page.  I cannot determine exactly what this error is because Custom Errors are turned on and I haven't been able to turn them off.
In the Event Logs, the following Application Errors can be found while the attempt to start the service is being made:
Warning - Event ID 10035 - Windows SharePoint Services 3 Search
Could not import the registry hive into the registry because it does not exist in the configuration database.

Context: Application 'bf3cdd2c-561d-4cd4-aba0-37ddf776115b'

Error - Event ID 10029 - Windows SharePoint Services 3 Search
Error backing up registry hive to the configuration database.

Context: Application 'Search index file on the search server'

      Access is denied.   (0x80070005)

Error - Event ID 2426 - Windows SharePoint Services 3 Search
Advise Status Change failed. The system is probably low on resources. Free up resources and restart the service.

Context: Application 'Search', Catalog 'index file on the search server Search'


Error - Event ID 4609 - EventSystem
The COM+ Event System detected a bad return code during its internal processing.  HRESULT was 80110472 from line 44 of d:\nt\com\complus\src\events\tier1\eventsystemobj.cpp.  Please contact Microsoft Product Support Services to report this error.

Error - Event ID 17 - VSS
Volume Shadow Copy Service error: The EventSystem service is disabled or is attempting to start during Safe Mode.  The Volume Shadow Copy service cannot start while in safe mode. If not in safe mode, make sure that EventSystem service is enabled. CLSID:{4e14fba2-2e22-11d1-9964-00c04fbbb345} Name:CEventSystem [0x80040206]

Error - Event ID 8193 - VSS
Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x80040206.

Info - Event ID 1314 - ASP.NET 2.0.50727.0
Event code: 4011
Event message: An unhandled access exception has occurred.
Event time: 10/5/2007 2:00:20 PM
Event time (UTC): 10/5/2007 6:00:20 PM
Event ID: 45ff281eeeae42a29b32c2841dd7d1fe
Event sequence: 162
Event occurrence: 1
Event detail code: 0
Application information:
    Application domain: /LM/W3SVC/1660259873/Root-1-128360762891562500
    Trust level: WSS_Minimal
    Application Virtual Path: /
    Application Path: C:\Inetpub\wwwroot\wss\VirtualDirectories\44905\
    Machine name: Z000ADS1
Process information:
    Process ID: 6856
    Process name: w3wp.exe
    Account name: SYSTEM\spadmin
Request information:
    Request URL: http://z000ads1:8080/_admin/SPSearchServiceInstanceSettings.aspx?ServerId=7f2668ae-ba24-44c4-88a9-16d4f3f8d7da&Provision=1
    Request path: /_admin/SPSearchServiceInstanceSettings.aspx
    User host address:
    User: SYSTEM\swing
    Is authenticated: True
    Authentication Type: NTLM
    Thread account name: SYSTEM\spadmin
Custom event details:

I have tried the following, to no avail:
- Disconnect from server farm and reprovision a new instance (multiple times)
- Delete the "C:\Program Files\Microsoft Office Servers\12.0\Data\Office Server\Applications" folder
- Uninstall and reinstall MOSS
- Use service account name directly, instead of DOMANNAME\<service account>

What could the problem be?
Question by:Macom
    LVL 15

    Expert Comment

    If this server is not yet being used, and no content is existing on it, uninstall SharePoint services, or SharePoint Server, and disconnect and delete all the related databases.

    Ensuer you have local admin rights on the computer(s) involved in the installation process

    Install SharePoint wss/server again, creating a new farm.
    Are you using SQL installed locally, or connecting to an existing instance?

    Author Comment

    I've already tried that.  I actually had to put in a call to Microsoft about this, they suggested doing it yet another time to no avail.

    SQL is installed locally.
    LVL 15

    Expert Comment

    for each service account that you are using, are they made members of the local administrator's group for the wss/sharepoint server? Also ensure if any group policies are applied, that the "log on locally as a service" is not overriding them from being able to actually run as services.


    Author Comment

    The service account used to setup SharePoint (database account) does have administrative privileges.  The search account does not.  I have used a similar setup on another SharePoint server without any problems.

    I just checked the group policy.  The search account does have "log on locally as a service" privileges.
    LVL 15

    Accepted Solution

    After seeing your "Access Denied" message for the search index files, seems to be permissions perhaps?

    Some items of note, when performing a complete uninstall (removal from farm, then recreation), you could disconnect from the farm, uninstall SharePoint Services / Server, disconnect and delete all SQL databases related to SharePoint, and then delete the /12 hive from folder structure.

    But before doing that, could you try adding your Search account to local administrators group? If you can determine it is permissions based, then can go back and remove/troubleshoot further.

    I remember using 7 service accounts, but after working with Microsoft and troubleshooting, even they recommended using one single service account on single-box implementations.

    Author Comment

    The Microsoft solution was to use the administrator's account as the search account.  After that I tried playing around with permissions but was unable to get it to work, unless I added it to the local administrator's account.  

    Unless I come upon a better solution, I'm going to just the administrative account as the search account.
    LVL 15

    Expert Comment

    Yeah, I like the idea of using all these service accounts and having granular control, but lately have revised my implementation to include the use of two accounts one for everything, except searchAccess. This way all the server-side items are running properly, and search/crawling is able to be run with a general account with nothing special.

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Join & Write a Comment

    SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
    On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!

    733 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now