Fedora 6 Samba Server Access Issue

Posted on 2007-10-05
Last Modified: 2013-12-06

I'm having issues viewing samba shares on a linux box from an xp client. I'm running Fedora Core 6 as the samba server (version 3.x.x). I am able to view the share names in windows, however, if I try to further access the shares I get the following after attempting to log in:

"\\\myshare-data is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The network name cannot be found"

I've set up a user account in linux, and then set up the corresponding user in samba via smbpasswd. I've also changed the permissions on the directories being shared to 777 to be sure it wasn't a permissions issue. I have attached my smb.conf here for reference:

#======================= Global Settings =====================================

# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
   workgroup = mydomain

# server string is the equivalent of the NT Description field
   server string = Samba Server

# Security mode. Defines in which mode Samba will operate. Possible
# values are share, user, server, domain and ads. Most people will want
# user level security. See the Samba-HOWTO-Collection for details.
   security = user

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
   load printers = yes
# This option tells cups that the data has already been rasterized
cups options = raw

# this tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/%m.log

# Put a capping on the size of the log files (in Kb).
   max log size = 50

# Backend to store user information in. New installations should
# use either tdbsam or ldapsam. smbpasswd is available for backwards
# compatibility. tdbsam requires no further configuration.
;   passdb backend = tdbsam

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The default is NO.
   dns proxy = no

#============================ Share Definitions ==============================
   comment = Home Directories
   browseable = yes
   writable = yes

# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
   comment = All Printers
   path = /usr/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes

path = /var/www/webdev
browseable = yes
valid users = timmy

Thank you
Question by:BiTRaTE2600
    LVL 19

    Expert Comment

    you are trying to access

    while you only have shared

    so you need to look for

    Also if you are having troubles with user/permissions it would be good to start with all permissions, then tight them. you can try with adding this line:
    force user = timmy
    and once everything works you can delete that line and test your permissions


    Author Comment

    Sorry, I messed up the post a bit. The error message I typed should have mentioned www-data instead of myshare-data. So that wouldn't be a source of the problem.

    No luck with force user = timmy either. I thought "force user" was to force file ownership if a file was added to that particular share? If that is the case, then this shouldn't have any effect on whether I can browse the share. I've tried leaving out the user entirely with no luck. I also tried "public=yes", which I believe makes it readable by anyone with no luck.

    Any other ideas?

    Thanks much for your response!

    Accepted Solution

    I just found the problem. When I installed FC6 I did not disable SE Linux, which was causing the problems. I disabled SE Linux in /etc/selinux/config and everything now works fine.

    LVL 1

    Expert Comment

    Closed, 500 points refunded.
    Community Support Moderator

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
    It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

    758 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now