We help IT Professionals succeed at work.

Unable to connect Outlook to Exchange

hoggiee
hoggiee asked
on
698 Views
Last Modified: 2008-07-17
I have just installed Win SBS 2003 together with Exchange 2003 on a server.  I successfully join my PC to the SBS 2003 domain.  However, when I connect Microsoft Outlook to Exchange 2003, I get the following error messages:
"Outlook could not log on.  Check to make sure you are connected to the network and are using the proper server and mailbox name.  Network problems are preventing connection to the Microsoft Exchange Server computer.  Contact your system administrator if this condition persists.  You can choose File->Work Offline to work locally until the server becomes available."

"The name could not be resolved.  The action could not be completed."

The client PC and Exchange Server are in the same LAN segment, no firewall blocking.  I have tried the following approaches:
- ping the Exchange Server name and IP --> got reply.
- connect using different user account from client PC --> failed.
- connect from different client PC --> failed.
- telnet to port 25 and 110 of Exchange server --> OK!
- connect with Outlook 2003 (initially was Outlook 2002) --> failed.
- install Outlook on the Exchange Server, and then connect to Exchange --> OK!
- after successfully connected Outlook to Exchange Server from within the server itself, test send and receive --> OK!
- access OWA from within the Server (http://servername/exchange)  --> OK!
- access OWA from client PC browser (http://servername/exchange) --> failed.

This problem is driving me crazy.  If not of the max limit of 500 points, I would be willing to offer 1000 points!  Please help.  Thank you.
Comment
Watch Question

Commented:
Is the Windows firewall on the server enabled and blocking the PC? Can you log on to the PC as the domain admin and get to \\servername\c$ ?

Commented:
Also does it work if you put the FQDN for the server in Outlook, i.e. server.domain.com? Or the IP of the server?

Commented:
Seems more like a DNS problem.  How is the IP address of the client configured?  Does your DNS server have an entry for the client (not necessary for the client to communicate with the server but will establish that the client was able to register itself with the DNS server)?

-saige-

Author

Commented:
Windows firewall is turned off on the server and is not blocking any.  I am able to log on to the PC with a domain admin account, and no problem getting to \\servername\c$.  I have also tried connecting to the server with FQDN and server IP address, but to no avail.

Commented:
You could try installing the OWA Admin tool to help with the OWA problem: https://www.microsoft.com/downloads/details.aspx?familyid=4BBE7065-A04E-43CA-8220-859212411E10&displaylang=en

It does sound like a DNS problem but could be an authentication problem. Can you log on to the workstation with the same user that you log on to the server (domain admin presumably) and see if you can set Outlook up under that account?
Make sure that client computers ONLY point to the SBS server for DNS. No other DNS server should be configured on the client computers.

Run IPCONFIG /ALL to determine this.

Author

Commented:
I've finally fixed the problem but am not sure which is in fact the correct cause.  I disabled the following security options in my DC's (which is also my Exchange 2003 Server) Domain Controller Security Policy:
- Digitally sign client communication (always)       Disabled
- Digitally sign client communication (when possible)       Disabled
- Digitally sign server communication (always)       Disabled
- Digitally sign server communication (when possible) Disabled
- Secure channel: Digitally encrypt or sign secure channel data (always)      Disabled
- Secure channel: Digitally encrypt secure channel data (when possible)      Disabled
- Secure channel: Digitally sign secure channel data (when possible)      Disabled
I will try each one by one when I am free to do this.  Right now, everything works OK, just leave it for now! :P
Thanks guys!

Author

Commented:
Admin, the problem was solved.  Please close this question.  Thank you.
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.