Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 884
  • Last Modified:

Can ping / telnet 80 but cannot browse the internet. Help!

Hello, I have a Windows XP (Home edition) Notebook PC.  All of a sudden I am unable to browse the Internet. The weird thing is I can ping other sites. e.g. ping www.google.com works fine. I can even telnet port 80 and use GET method to get content from sites.
e.g.
telnet www.google.com 80
GET / HTTP/1.1
...

This too works fine. I can see the response on the console.  I can even connect Yahoo messenger.

This is getting too frustrating :( I tried I.E, Firefox, Opera. Double checked IP/Subnet/DNS settings. Disabled all firewalls / antivirus. Resetted the XP TCP/IP protocol. But still no luck. It just says could not connect.

If I connect it to the LAN, I am able to browse network drives, etc :(

Any help would be highly appreciated.

Thanks,
Sid
0
siddharam16
Asked:
siddharam16
  • 3
  • 3
  • 2
  • +1
1 Solution
 
Farhan KaziSystems EngineerCommented:
Did you try 'WinsockXPFix' ?

Download it from:
http://www.snapfiles.com/get/winsockxpfix.html

Hope this helps!
0
 
siddharam16Author Commented:
Thanks farhankazi. Yeah I have it that too. But no luck yet.
One imp. thing to note is browsing is fine while in Safe mode with networking.


-Sid

0
 
bbrunningCommented:
It's either spyware on your system or a software firewall program causing the problems.
Do you use any of the following?
McAffee Internet Security
Norton Internet Security/360
ZoneAlarm

Disable the firewall completely on those if you do and try again. If that doesn't help uninstall the programs and try. If that still doesn't work, you have spyware. Post your results.

Also try adaware for spyware: http://www.download.com/3000-2144-10045910.html

bbrunning
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ncolyerCommented:
Try this:


Go to Internet Options in the Control Panel and Open it.

Click the connections tab then LAN settings

Make sure "Use proxy connection for your lan" is disabled.




0
 
ncolyerCommented:
Sid, try my solution above. I'm fairly confident this is your resolution. :-)
0
 
siddharam16Author Commented:
@ncolyer, there is no reference to any proxy server whatsoever.

@ bbrunning:: Actually I had norton security center installed.  A few days earlier I uninstalled it ..but there was some problem with the uninstallation. Although I cannot see the norton folder on my system, I can see it in the add / remove programs and I cannot even uninstall it :(

Again at the risk of repetition, I can browse if I am using the safe mode.

Thanks again.
-Sid



0
 
bbrunningCommented:
Norton Security Center integrates itself in your ipstack. it's possible that the corrupted uninstallation has stopped you from making any progress.
Download their uninstaller here:
http://service1.symantec.com/SUPPORT/tsgeninfo.nsf/docid/2005033108162039
Follow the link to the correct version and follow the instructions.
0
 
siddharam16Author Commented:
Thank you Thank you Thank you!

It was the norton installation that was playing foul! Thanks bbrunning
0
 
bbrunningCommented:
no prob! Thanks for the points!

bbrunning
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now