Telnet Timeout Issue

Ok gusy..

Two machines..

Machine 1:  Windows 2003 Server   ( has a telnet service running on it or server)
Machine 2:  windows xp just a client machine...  

machine 2 telnets into machine 1. works like a charm. However after a certain amount of inactivity or something the telnet session timesout. I don't want the timeout to happen at all. I want machine 2 to stay connected to machine 1 at all times.

I even get this message on the client machine saying...
"Telnet Server has closed the connection
Session timed out.

Connection to host lost."

Please help me solve this issue.  

Highly appreciated.
Who is Participating?
Farhan KaziSystems EngineerCommented:
You can set timeout settings of telnet server.

Click Start -> Run -> Cmd.exe

tlntadmn [\\RemoteServer] config [timeout=hh:mm:ss] [-u UserName-p Password]

For more info:
Farhan KaziSystems EngineerCommented:
If you are performing command on local server then

Start -> Run -> Cmd.exe

tlntadmn config timeout=00:30:00

This will set timeout setting to 30 mins.

and if you want to set timeout setting for remote server then

tlntadmn \\RmtServerName config timeout=00:30:00 -u Administrator -p P@ssw0rd

theitguyAuthor Commented:
thank you for you reponse... just curious intead of specifing the time as to how long to keep the session active...isn't there a way to just set the time to infinity or something..i mean the session is only terminated if the user decides to do that... else it stays active...
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

theitguyAuthor Commented:

also...right now when the session timesout... the window that is open sometimes goes dead.. .so you can't close it... i could not close it even by going to the task manager and using the end task ..... does not happen always but does happen time to time.. is that normal... or what?.

Farhan KaziSystems EngineerCommented:
>> .isn't there a way to just set the time to infinity or something
Yes! you can turn off this function by applying following command

tlntadmn config timeoutactive=no

You can help and further options using /? help switch like:
tlntadmn /?
tlntadmn config /?
theitguyAuthor Commented:
ok let met try that... also the post about where the window hangs and i cannot close it even with end task...

any thoughts on that?

Your help highly appreciate>
Farhan KaziSystems EngineerCommented:
It only hangs when Telnet session disconnects?

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.