[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1500
  • Last Modified:

Lost RAID5 array on Sil3114 controller

I have a problem with a RAID5 array on Sil3114 controller on my DFI NF4 SIL Expert, Opteron 175 running XP pro. I set up 4 x 500gb Seagate hard drives as a RAID5 for extra storage safety, my OS is on 2 x 74gb Raptors as a RAID1 with a image of the OS array stored on the storage array. Last week the last drive on the RAID5 array started dropping out from time to time, I thought it may be the PSU so I upgraded it with a bigger one. When I restarted Windows stalled, I thought the Sil3114 controller may be rebuilding the drive that was dropping out so I left it all day but it never got into Windows. I hit restart and the next time it restarted the Sil RAID utility showed the first two drives as a Parity RAID but the third and forth drive as "Available". I restarted and went into the SilRAID Bios but it has the first two drives as "Invalid Raid Drives" and the other two as "Reserved Drives". I've spent the last week searching the net for a possible fix for the problem but still can't find what I can do. Can anyone help me out?
0
greistokes
Asked:
greistokes
  • 4
  • 2
  • 2
  • +2
1 Solution
 
willcompCommented:
Since you are new to EE, just a note to assure you that us "experts" do look at questions. I don't have a ready solution for you and suspect that's also true for others who have read your question.
0
 
Shane32EECommented:
There's three possibilities: (1) the Sil RAID BIOS isn't working right and is 'forgetting' the RAID array settings, (2) the SiL RAID chipset is messing up the headers of the RAID array on the drives and probably also corrupting data, or (3) your hard drives are not saving or reading data properly.

If it's (1), then you can probably just recreate the RAID array in the Sil RAID BIOS and be up and running again.  I don't know of any manuals that say this is an 'approved' solution, but it works with LSI Logic MegaRAID controllers and their RAID arrays.

If it's (2) or (3), you can probably do the same thing, but you should then copy your data off, reformat, and reinstall Windows -- then reload your data.

Your probably probably isn't (3), as if the hard drives are bad, usually the Sil controller will report the drive as failed and continue running after a reboot on a RAID5 setup.  You can usually hear a failed hard drive if it's bad, anyway.  If it was (1), you'd think that all of the RAID configuration would be cleared from the RAID BIOS...not just 2 of the drives.  So I'd guess you've got a bad controller.

I'd probably start by buying a PCI addon Sil3114 card and hooking the drives to it (making sure the drives are attached in the correct order).  You can find them anywhere; I have one myself.  Then recreate the array and see what happens.  If there's no data loss, your PC will probably boot right up.  If it's imperitave that you recover the data, you might try using RAID Reconstructor to recover the data, or send the drives to a specialist.

I said 'probably boot right up' because Windows might not have the drivers installed for the new PCI addon card -- but probably will be fine since it would be the same Sil 3114 chipset.  If you have problems here, though, you know you can recover the data, even if it means hooking the driveset to another computer.

You could also make a sector-by-sector clone of the drives using Acronis Disk Director.  Then, try the above recovery steps on the cloned drives, leaving the original drives alone, in case you want to use other tools on them or want to send them to a specalist.

Hope this helps!
0
 
Shane32EECommented:
I'm rereading your question, and have more questions and comments.  What is your RAID1 array connected to?  Does the RAID1 array show as online?  Can you boot into Windows now?

If the one drive was dropping out from time to time, perhaps the drive was failing.  I've had batches of drives all be bad, all failing sooner or later -- perhaps that's your problem.  Do you have a fan installed of your drives?  Often drives fail because of insufficient cooling -- especially in a system with multiple hard drives installed -- and other faulty drives can often be saved by providing adequate cooling.

If the OS is on the RAID1 array, it should be very easy to connect a PCI Sil3114 controller to your computer and try connecting the drives to it.  At least, it would tell you if it can recognize the drives any better than your onboard card can, or if it doesn't try to.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
greistokesAuthor Commented:
Shane, thank you for your reply. The RAID1 is on the NF4 controller and it has my windows install on it. The RAID5 on the Sil3114 is solely a storage drive but it does contain my "my Documents" folder.
I have tried the RAID5 on my other computer (P5AD2 Dlx,  Sil3114 but with a different bios) and it came up the same. It recognises the 2 drives as being in an unavailable RAID5 array and the other 2 drives as available.
I have order a PCI Sil3114 card which is in the mail and should arrive today,  the problem is it doesn't mention handling RAID5 at all.
I went out to get 4 hard drive yesterday so I can clone the drives before I play with them but I couldn't find anywhere that had Seagates in stock. I could get Maxtor or WD but I always prefer to clone to identical drives and as Seagates are are down to $150 now, I can afford it. I contacted a specalist company who told me it would cost from $1500 but as  I'm a person not a company, I  can't afford that. I'm pretty sure the drive was dropping out due to not having enough power not heat. The drives are fan cooled and the Mobo, GPUs and CPU are watercooled so the hard drives barely get over 50C.
Thanks again for your help, I hope it works and I'll let you know my findings.
0
 
Shane32EECommented:
Sure, no problem.  I know the Seagate drives are rated up to 50C, but I've had some very bad experiences recently with certain Seagate drives going bad when they were just getting warm, not hot at all.  I RMA'd the drives and replaced them in that computer 3 or 4 times.  It was one of those mini cases, and after I put the rear fans to 100%, the rear drive didn't go bad again, but the case never could keep the front drive cool enough.  Eventually, I pitched the case since it seemed that the particular model Seagate was giving me was very susceptible to heat, even though the drives never reached anywhere near 50C.  The drives work great now in the new case with a 120mm fan in front of them.  Of course, perhaps it was a power issue (it shouldn't have been), but other than others of the same model went bad too.  On the other hand, I've never had problems with other Seagate drives and still always use them.

At least you know, by putting the drives on the other MoBo, that the drives are currently in a corrupt state.  And if you really think it was a power issue, then it's probably likely that the data was corrupted by the HD because of the PSU, and maybe you won't have any more issues now that you've replaced the PSU.

Hopefully after you clone the drives you can just recreate the array in the Sil 3114 bios and be able to copy your data off.  By the way, after you recreate the array, you might want to disconnect the 4th drive so that just in case the drives are in an inconsistent RAID state, you don't have inconsistent results while reading the drive.  Then, if everything looks good, you can connect the fourth RAID drive and let the Sil3114 bios recreate the 4th drive from the other 3, so that the RAID array will be consistent.

Shane
0
 
willcompCommented:
If needed, here's a source for 500GB Seagate drives.

http://www.newegg.com/Product/ProductList.aspx?Submit=ENE&N=2010150014+50001305+103530113+1035915133+1036007800&Configurator=&Subcategory=14&description=&Ntk=&srchInDesc=

Operating temperature range is 0 - 60 degrees C for most Seagate drives. Seatools for DOS will provide highest temperature reached by drive.

0
 
Shane32EECommented:
rindi,

As you can see, I spent extensive time answering the author when nobody else did.  He replied to me, and finished with "thanks again for your help, i hope it works and i'll let you know my findings."  I also answered that reply, but he never replied back to me.  I believe that I should be awarded all of the points for this question.

Thanks,

Shane
0
 
greistokesAuthor Commented:
Sorry to take so long but it takes a long time to do anything when one is dealing with 1.4 TB.
What I ended up doing was:
Buying the same drives and cloning all the drives, then I tried to use "Quick Recovery Raid5 De-Stripper" to get the data back. Waste of time. Although Physically the drives were on SATA5~8, it seems that that is not the order they were striped.
I then re-built the raid with the new drives to see what order they were striped (8-7-5-6) and since then I have been trying to get the data back using Restorer2000 pro, it has a virtual raid section but drive 8 (the bad one) has bad blocks and so scanning that took 3 days and the data wasn't found. Since then I have tried to subsitute drive 8 with a bad empty drive and scan that using different drive orders, I have tried 3 different orders so far and still can't find the data. I am now trying to find out what block size and order the Sil controller uses but I can't find the info anywhere. So far Shane32EE has been the most helpful but the solution has not been found. As I am no longer a member here, I was only trial, I have logged back on just to conclude  this question. I will award half points to Shane and half to myself as I will be the one that finds the answer eventually. Thanks again Shane.
0
 
rindiCommented:
Have you checked the raid reconstructor, and getdataback (you probably will need both, first the raid reconstructor to recover the the array, and after that getdataback to recover the data from the reconstructed images)?

http://runtime.org
0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now