• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 683
  • Last Modified:

How to change OpenSUSE WLAN network preference

I need to prevent OpenSUSE from connecting to my neighbor's WLAN AP and make sure it connects seamlessly to my AP when in reach.

I have laptop just installed OpenSUSE 10.2 x86_64 updated with whatever OpenSUSE recommended, installed with fglrx driver from ATI, sk98lin from Marvell, powernow from AMD, and broadcom wireless using ndiswrapper with 32bit XP driver, since included bcm43xx did not work even with firmware.

I need my computer to prefer my AP (non-broadcasting, WPA) over neighbors one (broadcasting,unencrypted)
And I need some way to store WPA key so I am not asked for it again and again.

0
gheist
Asked:
gheist
  • 4
  • 3
1 Solution
 
gheistAuthor Commented:
To add a bit: I do use KDE and configure net using "NetworkManager" and prefer to solve problem using theese tools.
Please do not suggest other distros, they do crash & hang booting up on this laptop - Ubuntu,Mandriva,Knoppix,Fedora were tried
0
 
pablouruguayCommented:
i think you need to use iwconfig and iwtools to do that is more efficient. che for that
0
 
gheistAuthor Commented:
I cannot because ndiswrapper renders these tools useless...
I need UI solution or writing WPA key to config files or smth like that.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
pablouruguayCommented:
mmmm i have a rt2500 with ndiswrapper and iwtools and configure the card with iwconfig simple, anyway i dont know other option to cofigure wpa in UI mode.

0
 
pablouruguayCommented:
1 question.   you can use yast for that ... you try it?  

http://www.linuxheadquarters.com/howto/networking/yast_ethernet.shtml
0
 
gheistAuthor Commented:
I have solved problem by myself - In KNetworkManager window I select Options/Show Networks...
Then I Drag&Drop my networks name from Non-Fallback to Falback, and it uses kdewallet stored password and prefers my network over neighbors network.
I have not yet tried YaST, but I have tried editing wpa_supplicant.conf and setting network key there - it worked just fine. I will get heroic some day this week and try YaST method. If it works you get A if not You get B. Thanks for (trying to) help.
0
 
gheistAuthor Commented:
YaST can be configured to attach to single network automatically. I will stay with NetworkManager.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now