Link to home
Create AccountLog in
Avatar of jabroni1888
jabroni1888Flag for United States of America

asked on

Can only get to google

I have a small network with a Windows 2003 server and 10 workstations.  Earlier this week we were unable to surf the web and we could only get to google.  I checked with the ISP (SBC/AT&T) and they say everything is fine.  I unpluged the dsl modem and router (linksys BEFsx41) for 15 minutes - no change.  The server has SP2 and all the latest updates.  All of the workstations use the server for DNS, so I thought the DNS on the server might be messed up.  I brought my laptop in from home and got it on the network (using the server for DNS) and I can get on the internet fine.  But the server and the workstations still can only get to google.  So I was thinking that is might be a virus or malware.  I am currently running a virus scan on the server and on one workstation (norton corp 10.0.2.2020)
Avatar of Alan Huseyin Kayahan
Alan Huseyin Kayahan
Flag of Sweden image

    Hi jabroni1888
           *In a client, Start>Run>Cmd then type nslookup.
           *Now type www.google.com then type www.hotmail.com . If both of the queries return the IP addresses, then DNS is fine, might be something browser related or malware.
           *If a domain exists, join the notebook you brought from home to domain and see problem exists. If yes, that might be something policy related (Fake proxy may be set by policy with google.com exception)

Regards
Avatar of jabroni1888

ASKER

Thanks for the info.
I did a few nslookups on the server (google, msn) and the first nslookup for all sites that I tried failed.
error message ' can't find server name for address 192.168.1.5: non-existent domain server: unknown'
     What is the Ip of Windows 2003 server ? 192.168.1.5 ?
      And the IP of linksys?
The server IP is 192.168.1.5
The linksys router IP is 192.168.1.1
> .. can't find server name for address 192.168.1.5
your DNS server is not configured properly, either adjust your DHCP settings (may be the router), or set the DNS manually in each workstation
Do you probably have to DHCP server running (on the server and the DHCP router)?
    First of all, create a reverse lookup zone in DNS (if it already exists, jump to other step)
     http://technet2.microsoft.com/windowsserver/en/library/c12222ef-8350-48bc-8b48-25f78681d2a01033.mspx
     Then create a PTR record for server (Navigate to "Adding a PTR Record Later" section in article below)
     http://technet.microsoft.com/en-us/library/bb727018.aspx
    In DNS server properties, click on Forwarders tab. Make sure 192.168.1.1 is listed there, if not, add it.
   Make sure in TCP/IP properties of server, preferred DNS server is 127.0.0.1
   After doing these changes, flush the DNS cache, stop DNS service, then start DNS service
   In client, right-click the Local area connection in my network places properties,then click repair


   
Reverse DNS is setup on the server and a PTR record exists
The TCP/IP properties of the server has 127.0.0.1 as the DNS server
I flushed the DNS on the server and restarted the DNS service
On the server I am to run an nslookup - tried google and msn and both worked
I am still not able to get to many web sites.  The only sites I can get to come up are google and linksys
    So now, when you type nslookup and query some sites www.msn.com www.yahoo.com https://www.experts-exchange.com , you get responses the IPs, and still can not browse via Internet explorer. Then this is most probably a fake proxy issue.
    *Start>Run>rsop.msc
    *Navigate User configuration>Windows settings>Internet explorer maintaince>Connection>proxy settings. Check if a proxy is defined. If not, check the proxy settings in Internet explorer settings of local machine.

I updated the firmware on the router and then the internet worked fine
Last week the ISP changed DNS serves and for some reeason that made the router unhappy, but once I updated the firmware everything worked.
ASKER CERTIFIED SOLUTION
Avatar of ahoffmann
ahoffmann
Flag of Germany image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
  No way :) That error can not be firmware related.