We help IT Professionals succeed at work.

HP / Compaq Proliand DL 580 G2 boot display issues

1,655 Views
Last Modified: 2010-04-21
I have a Compaq / HP Proliant DL 580 G2 server that appears to post w/o error.  When I attempt to use the FW maintanence CD or the smart start CD the box will boot to the CD show the splash screen, load to 100% then the screen goes dark almost like the resolution is to high for the monitor....but it's not?  i've looked for some kind of a console redirect that might be in place that would redirect video output to another port....I can't find anything...or just am not looking in the right place...either way if a console redirect was in place the monitor should not display at all, right?  the server has and iLO port, an onboard video port, and a serial port (NIC, USB, too).  The iLO access works just fine...i can access the iLO features and perform all functions that it provides.  The only error i do see is a post 1794 error about the accelerator battery charge is low....but the device has been unplugged for about 2 months....I can't imagine this would be the cause of my issue?  The bios is current for this model....and I can't update anything due to the display issues, but everything appears to be no more that 2 version/upgrades from the current for this model...

..any ideas??

Thanks
Comment
Watch Question

Hello,

Battery low for accelerator will be recovered automatically when you power the for a few days, if not, consider to upgrade fw for this component, you can use a downloaded soft from HP for upgrade all the drivers at same time. If you can connect with iLO the box seems to be in good condition. If you suspect for the video (resolution, video card, ...) you can power up the box and when ready connect to it from another PC with Atelier (download free from http://www.atelierweb.com/rcomm/index.htm). Atelier can connect remote console to Proliant and gives a logon screen for you.

Don't hesitate contact again for any question.

Author

Commented:
jordibartrina, thanks for the quick response...what's strange is when i run the iLO remote console it does the same thing....splash screen, load, then blank screeen....the box has to be rebooted.  It's very strange...presently there is no OS on the box...If I'm building/installing a single server usually boot to the maintanence cd to upgrade / update FW then use the install cd to install the OS...make it easy for install of necessary drivers, system partitions, etc....
here is what i have attempted so far
1. booted to HP firmware maintenance cd....screen went blanks after loaded to 100%
2. booted to HP smart start cd...screen went blank after loaded to 100%
3. booted to windows 2003 server CD...hung at starting windows...this might be because i missed the key to install third party raid controller driver...will try that again
4. replaced drives with 2 new drives and tried 1, 2, and 3 again...all failed

is there a jumper or switch on the server itself that redirects video output that i may be missing?  
very strange....

CERTIFIED EXPERT
Top Expert 2007

Commented:
Could it simply be a flakey VGA card on board ?

Have you tried with a bootable Linux like knoppix or Ubuntu ?


I hope this helps !



Author

Commented:
I will give that a try....the fact that it does the exact same thing every time is a bit strange...the consistent failure is what has me thinking it's a switch, jumper, or config of some kindconfused?  I will try your suggestion...and let you know...

thx

Author

Commented:
when i attempt to boot to a Linux AS4 cd it reports hda: lost interrupt....over and over again...i suppose it could be a device in the system that is conflicting with the video card....i/o or irq??  I did notice it has 3 broadcom gig nic's in not onboard these are aftermarket...i will try to remove them and see what happens...i will feel really bad if that's the issue.....  :-)

Author

Commented:
well the cards are not the issue...i pulled them all and tried all all three steps again....still same results...black screen its like it wants to display but can't   :-)
I know the monitor will do 1200x1600 so it's not out of range for the monitor...the condition is just so consistent....there has to be something I'm missing in a config somewhere....
CERTIFIED EXPERT
Top Expert 2007

Commented:
I would pull the Maintenance manual from the HP site, and check for any config switches.  Make sure they are all in the default position for a start.

If  you can not get this to work, and it is under warranty, it is time to call HP for support.


I hope this helps !

 

Author

Commented:
alright...now it's getting strange...i have another of the same server...i threw a quick image on it threw the drives in the server giving me grief....the box booted right up?!?!?!?  emulation program sees it and all is good?  I'm very confused now...looks like this one is going to test test enviornment...I'm going to leave the question open for a few days to see if anyone else has some ideas on this...
thanks for your help....if you can think of anything else that i should check let me know.....in the meantime I'm going to grab a copy of the server manuals and see if anything jumps out at me there.....

Author

Commented:
HP indicated the nvram might be corrupt....i should clear nvram....or maybe the rom and redundant rom may be corrupt....only issue is I did not see any errors to that effect in the logs anywhere.....I will look into it more tomorrow
Hello again,

Have you tried with another monitor? Some proliant with 15" HP CRT (I don't remember model) gives the same problem.
andyalderretired saggar maker
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
"unplugged for about 2 months" would certainly hint at NVRAM getting confused.

You will get blank screen on iLO once it goes to graphical mode under the Linux based firmware and maintenance CD unless an ILO advanced pack license is installed.
CERTIFIED EXPERT
Top Expert 2007

Commented:
Sounds like it may be a motherboard issue.

Again, if under support, get HP to fix it !

retired saggar maker
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
andyalder - I do have the iLO advanced pack license installed...which is what's strange about the display issue...with a set of imaged HDD's all is good with the box...I think I'm going to clear nvram and see what happens...i have updated all the firmware as of now...
jordibartrina - I tried another monitor a 17" and it gave me the same grief...
sysexpert -  I was thinking MB issue...but the last MB issue i had with one of these server the issue's were not consistent...one time it would boot, next it would not boot, then it would just shut down...etc...presently it's doing the exact same thing every time...strange...i guess it could still be the MB....

I will post an update following an NVRAM clear....

Author

Commented:
flushed NVRAM and check all internal connections.  Device is back online

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.