Blank pages

Posted on 2007-10-08
Last Modified: 2008-11-17
I have a problem with opening some pages. I noticed that the pages not opening have something to do with HTTPS, e.g. hotmail and gmail, and whever we have a page that requires new registration or sign in. Even on, and when trying to finalize this question, I could complete it to the end. Hotmail/Gmail home page opens, but after trying to sign in, i get a blank page. This problem occured suddenly. These sites open normally on the isa server.

Our Setup:
I have ISA 2004, IIS, multiple servers (DCs, exchange). ISA is being used as firewall only, not as a web proxy (Clients don't specify a proxy address).

In the live connection log, I receive the error "0x80074e24 FWX_E_CONNECTION_KILLED" when trying to complete the sign in. Also I receive 0x8007420 FWX_E_GRACEFUL_SHUTDOWN.

In the event viewer and in ISA monitor, I get the follwing:
"Event ID: 14148. The Web Proxy filter failed to bind its socket to (ISA IP address) port 8080. This may have been caused by another service that is already using the same port or by a network adapter that is not functional. To resolve this issue, restart the Microsoft Firewall service. The error code specified in the data area of the event properties indicates the cause of the failure."

I have restarted the ISA server mutiple times, but no success.
Question by:bluesand4

    Author Comment


    I noticed that when clients have Vista, every thing works fine. Who has XP, he will have the problem

    Author Comment

    no one can help??
    LVL 21

    Expert Comment

    If you use your ISA as firewall you can disable the webproxy filter. That will clear the error in event log.
    The connection killed error comes from Web filter that has some problems in interpreting this trafic.

    LVL 51

    Accepted Solution

    Because you have not used the web proxy service in ISA, ISA will only be looking at the lower layers of the traffic.
    In addition, some of the return traffic may get blocked because the service is not being utilised.

    You do not state what service pack of ISA2004 you use - I'll assime you have SP3 as that is the latest.

    Open the gui, select monitoring - logging - click start query.

    try a connection to a site that goives you trouble - what do you see in the log?
    Do not make the connection from the ISA server itself - this will give spurious results as the proxy isn't being used - do it from a client machine.

    Do the same from a Vista client - do you see anything different in the logs?

    Featured Post

    Better Security Awareness With Threat Intelligence

    See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

    Join & Write a Comment

    There are three types of ISA client that can be configured - these can be individual clients or multiples of a client on each PC or server SecureNAT. A SecureNAT client for ISA server is a client machine, work station or server, that has its defa…
    Forefront is the brand name for Microsoft's major security product. Forefront covers a number of specific security areas and has 'swallowed' a number of applications under this umbrella including Antigen, ISA Server, the Integrated Access Gateway (t…
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now