• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 283
  • Last Modified:

Remove login prompt in web

I have a web form that asks for a login when I initially open the db it already asks for login, but when I click on href it asks again for a login and the password is not accepted. The href is a simple OpenForm. Question is how can I remove the login totally from this web application.
0
aentice
Asked:
aentice
  • 3
  • 2
2 Solutions
 
Bill-HansonCommented:
To remove all access restrictions, set the Default ACL setting to "Editor".

Otherwise, if you still need to secure parts of the application, there are several options depending upon the target of the link and your current settings.

(1) If the link tries to compose a form on another server, you will need to enable Multiple Server authentication (SSO).
(2) If the link tries to compose a form in the current database, but the user has only Reader access to the database, then the form must be "Available to Public Access users" (security tab of form properties).
(3) Check the "Maximum Internet name and password" setting in the database ACL (advanced tab).  You may need to set it to "Editor".
(4) Check the ACL.  You may need to increase the level for this user.
0
 
madheeswarCommented:
Give Anonymous in the ACL as reader and above.
0
 
qwaleteeCommented:
Bill,

Available to Public Access users -- is this wokring on the web now?  I'm probably out of date.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Bill-HansonCommented:
Yes, it works now.  I'm not sure which release fixed it, but it works great for creating input forms that don't get saved to the database.

Anonymous with "Reader" access and "Write public documents" enabled will be able to execute "?OpenForm" commands for any form with "Available to Public Access users" enabled without further authentication.
0
 
Bill-HansonCommented:
That reminds me...

Maddy's right about giving Anonymous reader or above access, but in order for my suggestion using "Available to Public Access users" to work, Anonymous also needs  "Write public documents" enabled.  (This also works for "Depositor" access).
0
 
madheeswarCommented:
Why "B"? If our proposed solution is not the correct answer, you would have asked for better solution. You never turned up to respond to our suggestions.
This is unfair...
Please ask a post a question (Zero point) in Commnuity Support with this thread link and ask for change in grade to "A".
Thanks and regards,
Maddy
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now