HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.

Hello Experts:

I have messed up my permission for my website--I apparently did it when I uninstalled microsoft exchange off of my SBS server.  I can access my company website from within the company--but from the web--I get the following:
HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials. Internet Information Services (IIS)

Does anyone have any idea how to fix the problem.

Thanks
huntersp3Asked:
Who is Participating?
 
Jeffrey Kane - TechSoEasyConnect With a Mentor Principal ConsultantCommented:
Follow the steps outlined here:  http://support.microsoft.com/kb/822699

Jeff
TechSoEasy
0
 
budchawlaCommented:
You uninstalled Exchange from SBS? Why? ? ?

You're running a public website on your SBS server? Why? ? ?

OK but anyway, you probably need to disable authentication of any sort and allow anonymous access to your website if you want it publicly accessible.

Bear in mind that both things that you mention are contrary to best practices!
0
 
huntersp3Author Commented:
Hello Budchawla:

I uninstalled Exchange from SBS because I am now running Exchange 2007 on it's own seperate mail server--following the article installing exchange 2007 into a small businsess server 2003 domain produced by MSExchange.org.  When I inherited this job, they had the website running from the SBS and I haven't had a chance to move it off to it's own server.  I will double check the anonymous access again.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
huntersp3Author Commented:
Hello Budchawla:

Any other suggestions?  I am still getting the error.  I restarted the IIS services but still no joy.
0
 
budchawlaCommented:
Hi, did you allow anonymous access to the website?
0
 
huntersp3Author Commented:
Yes, I did
0
 
budchawlaCommented:
On the directory security tab, click Edit for IP address and domain name restrictions and change it to by default all computers will be granted access...

BTW, what message do you get when trying to access the site?
0
 
huntersp3Author Commented:
I have checked the Directory Security Tab and Edit for IP Address and domain name restrictions and it was already set to by default all computers will be granted access.  When I try to access the site from the internet I get the following web page displayed:

You are not authorized to view this page
You do not have permission to view this directory or page using the credentials that you supplied.
--------------------------------------------------------------------------------

Please try the following:

Contact the Web site administrator if you believe you should be able to view this directory or page.
Click the Refresh button to try again with different credentials.
HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 401.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Authentication, Access Control, and About Custom Error Messages.
0
 
huntersp3Author Commented:
I wonder if my passwords are out of sync.  How to I resync them?
0
 
budchawlaCommented:
BTW, is this the default website that you're trying to view or a sub-site?
0
 
budchawlaCommented:
Which passwords? If you want a publicly accessible site then there should be no passwords involved?
Also, is this website working inside the network?
0
 
huntersp3Author Commented:
Should I just uncheck the anonymous access.  I am refering t the  IUSER_computername account.
0
 
huntersp3Author Commented:
Hello Bud or Anyone:

I believe my anonymous account password is out of sync with AD & IIS--what are the steps for resyncing the passwords?

Thanks
0
 
huntersp3Author Commented:
Hello Jeff, Bud and Anyone Else:

I tried the link that Jeff suggested and still I have a permission problem going on with my website that I can't figure out.  Let me state all the facts about the problem.

Recently, I moved from SBS Exchange 2003 over to Exchange 2007 and followed the directions in a article from MSExchange.org and all went well.  The last step in the article was to uninstall Exchange 2003 and did so with no issues (or so I thought)--I did this last Thursday.  Apparently, at that time my website ceased to be online and I did not discover this unit yesterday (Monday morning).  Here is what the site is doing.  Within the network I can open a web browser and type in www.mydomain.com and access the site with no problem.  In addition, I can open IIS 6.0 and go the default web site right click and browse the site with no problem.  When I am off site--if I try to access the website from within a IE 7 browser I get the "HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)" as stated above.  If I try to access the website from within a IE 6 browser, I get a username and password dialog box.  If I type in my username and password then the website comes up with no problems.  I know it is an authentication problem but I can't seem to find a fix for it.  I have tried resetting the passwords for the IWAM_ComputerName Account and ISUR_ComputerName Account--but still have the same issues.  Does anyone have any ideas--I would appreciate the help!

0
 
huntersp3Author Commented:
Hello Everyone:

I have an update.  It is something wrong with my ISUR_ComputerName Account.  I used another account name in IIS 6.0 under Directory Security and got the website to come up with no problems.  Any suggestions on how to get the ISUR_ComputerName account back to normal working order?
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Other than resetting the password per the KB Article I linked above, you can actually just delete the account, and restart the IIS Admin Service to recreate it.  See http://support.microsoft.com/kb/822165

Jeff
TechSoEasy
0
 
huntersp3Author Commented:
Thanks Jeff...that solved the problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.