• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 251
  • Last Modified:

ActiveDirectory and ASP.NET 2 Login control is requiring full login name (ie login@domain)

I'm using ActiveDirectory with the ASP.Net 2 login control. For some odd reason the login control is requiring the user enter their full login name, including the domain. For example jdoe@acme.fireworks.
Anybody have any idea why?
0
dmoss123
Asked:
dmoss123
  • 3
1 Solution
 
dlangrCommented:
you should probably define domain=<yourdomain>
0
 
dmoss123Author Commented:
Where do I define the domain? Is this in a config file?
0
 
dmoss123Author Commented:
Is this where I set the domain? I'll try it soon as I get to work. If it works I'll give you the points.

<forms name=".ASPXAUTH" loginUrl="login.aspx"
       defaultUrl="default.aspx" protection="All" timeout="30" path="/"
       requireSSL="false" slidingExpiration="true"
       cookieless="UseDeviceProfile" domain="<------------DOMAIN NAME GOES HERE>"
       enableCrossAppRedirects="false">
  <credentials passwordFormat="SHA1" />
</forms>
0
 
dmoss123Author Commented:
I found the following  microsoft solution http://msdn2.microsoft.com/en-us/library/ms998360.aspx

You can change the name mapping so that it uses simple user name format by setting the following attribute in the Membership Provider configuration in the Web.config file.

attributeMapUsername="sAMAccountName"

I'll be trying it in about a half hour
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now