Gong Server on Red Hat Linux JSP errors and Moodle

Posted on 2007-10-08
Last Modified: 2013-12-06
I'm trying to integrate a voice recording software called Gong ( into an online instruction package called Moodle (  I cannot get Gong running on its own, so I'm not even at the Moodle part yet.  Gong requires Tomcat and a specific version of the Java 2 SDK to work. I am following their installation instructions to the letter but when I try to log into Gong I get the following JSP error:

HTTP Status 500 -
type Exception report
description The server encountered an internal error () that prevented it from fulfilling this request.
root cause
note The full stack trace of the root cause is available in the Apache Tomcat/5.0.28 logs.
Apache Tomcat/5.0.28

I have tried several different versions of Java, and I've even tried an entirely different box with a different distro and I'm still having the same problems.  I've written down my installation instructions from start to finish, hoping that someone can see a mistake I'm making along the way.

With a fresh install of Red Hat Enterprise 5 or Fedora 7, same results either way.  With the default install there is no Java on the machine.

1)      I download the Java 2 SDK ( from Suns archive at
2)      I run the command chmod +x j2sdk-1_4_2_08-linux-i586.bin
3)      I run the install with ./j2sdk-1_4_2_08-linux-i586.bin.  I agree to the Sun legal agreement and the files are extracted.
4)      I move the newly extracted directory to /usr/java with mv j2sdk1.4.2_08 /usr/java
5)      I add JAVA_HOME="/usr/java/j2sdk1.4.2" to /etc/profile
6)      I add export JAVA_HOME to /etc/profile
7)      I reboot
8)      I type echo $JAVA_HOME to make sure the environment variable is working
9)      I create a tomcat group with groupadd tomcat
10)      I create a tomcat user with useradd -g tomcat tomcat
11)      I download Tomcat 5.0.28 from
12)      I extract it with tar xvzf jakarta-tomcat-5.0.28.tar.gz
13)      I move it to /usr/local/ with mv jakarta-tomcat-5.0.28 /usr/local/
14)      I create a symbolic link with ln -s /usr/local/jakarta-tomcat-5.0.28 /usr/local/jakarta-tomcat
15)      Change group and owner with chown tomcat.tomcat /usr/local/jakarta-tomcat and chown -R tomcat.tomcat /usr/local/jakarta-tomcat-5.0.28
16)      I go to /jakarta-tomcat/bin and type and make sure Tomcat starts with no errors.  Then I shut it down.
17)      I add the following to the tomcat-users file <role rolename="admin" /><role rolename="manager" /><user username="administrator" password="administratorpassword" roles="admin,manager"/>
18)      I download Gong from
19)      I extract the Gong zip to /usr/local/gong
20)      I start Tomcat with
21)      I go to http://localhost:8080 and click on Tomcat Administration
22)      I type in the username administrator and password administratorpassword
23)      I click on Tomcat Server (on the left) and then Catalina and then Host
24)      On the right frame I choose New Context from the drop down menu
25)      In the New Context I set the Document Base to /usr/local/gong
26)      In the Path I set /gong
27)      I click Save and then Commit Changes
28)      I reboot
29)      After reboot I go to http://localhost:8080/gong/admin and get the Gong Administration Page
30)      I type in the username admin and the password admin.  At this point I get the 500 error.

This has been driving me crazy for over a week now.  Any help would be greatly appreciated.

Question by:wirikidor
    LVL 11

    Expert Comment

    The war you are deploying contains jar with following class

    Author Comment

    @ karanw: I'm sorry is that a question?  I am not following what you are asking.

    Author Comment

    The solution to the problem is I need xorg-x11-deprecated-libs installed.
    LVL 1

    Accepted Solution

    PAQed with points refunded (500)

    EE Admin

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Are you sitting there reading this and wondering how to get started with Linux? It almost seems like picking the right Linux distribution is about like picking the right college or buying a new car if you read some of the article out there. Relax… l…
    1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now