[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

IIS 6.0 website session expire in every  2 min to 15 min

Posted on 2007-10-09
6
Medium Priority
?
899 Views
Last Modified: 2011-09-20
Hi,

I have a website named www.zoomtra.com, it's related to domestic fare and hotel online result, I have an issue the website session are expire  automatically in every   2 min to 15 min, Is there any IIS 6.0  setting the  session will not till 1 hour .

Regards,
Naresh
0
Comment
Question by:sitg
  • 2
  • 2
  • 2
6 Comments
 
LVL 23

Expert Comment

by:Ashish Patel
ID: 20039646
By default an application pool will be configured to shutdown after 20
minutes if it has been idle. To absolutely sure that the user gets the full
allotted period of timeout this value needs to be the same or larger than
the session timeout.

You can find it by first checking which application pool your application is
assigned to in the application folders propeties home directory tab
(probably DefaultAppPool).

The open the properties of the pool. On the performance tab change the idle
timeout.
0
 

Author Comment

by:sitg
ID: 20039669
We have already done this changes (90 mins) , but still facing problem.

Naresh
0
 
LVL 37

Expert Comment

by:meverest
ID: 20039694
have a look in event view application log - is there any mention of web applications failing and/or being recycled?
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 

Author Comment

by:sitg
ID: 20039706
there is no error related this issue.

Naresh
0
 
LVL 37

Expert Comment

by:meverest
ID: 20039719
is this a relatively busy site?

on application pools property page performance tab, try setting maximum worker processes to '1'

Cheers.
0
 
LVL 23

Accepted Solution

by:
Ashish Patel earned 1000 total points
ID: 20039754
Try this
To configure application pool idle timeout by using Adsutil.vbs
1.
 In the Run dialog box, type cmd, and then click OK.
 
2.
 At the command prompt, type:

cscript %SystemDrive%\Inetpub\AdminScripts\adsutil.vbs set W3SVC/AppPools/ApplicationPoolName/IdleTimeout n

Replace n with the number of minutes of idle time to allow before shutting down the idle worker process; the default time-out interval is 20 minutes. Timeout should be between 8 to 90 mins.
 
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Lync server 2013 or Skype for business Backup Service Error ID 4049 – After File Share Migration
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question