?
Solved

Cant connect to VPN server using windows vpn client behind Pix

Posted on 2007-10-09
5
Medium Priority
?
382 Views
Last Modified: 2008-01-09
Experts,

All my machines behind Cisco PIX 506e cant connect to vpn server located in some other country. If i connect a client directly to the router (without pix) it can connect. So that means something in pix is creating connection problem.

All clients are using Windows VPN client and TCP port 1723 is opened in pix as well as gre is allowed in pix. I am getting 'Error 721 with message 'The remote computer did not respond ----

Please see below my pix configuration. Could some one tell me what could be the problem.

Thanks

Qman
---------------------------------------------------------------------------------------------

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password /ZVdFkGdwW8wOhAv encrypted
passwd /ZVdFkGdwW8wOhAv encrypted
hostname pixfirewall
domain-name abc.com
no fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.25 lt
name 192.168.1.152 A
name 192.168.1.142 A
name 192.168.1.27 AD
name 192.168.1.187 HM
name 192.168.1.31 nv2
name 192.168.1.32 nv1
name 192.168.1.35 IT
name 192.168.1.34 nv3
name 192.168.1.43 lLT
object-group service AllowedPorts tcp
  port-object eq ftp
  port-object eq ftp-data
  port-object eq https
  port-object eq www
  port-object eq pop3
  port-object eq smtp
  port-object range pptp pptp
object-group service DNS udp
  port-object eq domain
object-group service RemoteDesktop tcp
  port-object range 3389 3389
object-group service Proxy tcp
  port-object range 8080 8080
object-group service TestPort tcp
  port-object range 6060 6060
object-group service sh tcp
  port-object range 1001 1001
object-group service a tcp
  port-object range 4800 4800
object-group service BloombergUDP udp
  port-object range 48129 48137
object-group service BloombergTCP1 tcp
  port-object range 8194 8198
object-group service BloombergTCp2 tcp
  port-object range 8209 8220
object-group service BloombergTCp3 tcp
  port-object range 8290 8294
object-group service Gmail tcp
  port-object range 995 995
object-group service GmailSMTP tcp
  port-object range 465 465
object-group service MSN tcp
  port-object range 1863 1863
  port-object range 8080 8080
object-group service Anchorfree tcp
  port-object range 8041 8044
object-group service BlockedSites tcp
  port-object range www www
object-group service www tcp
  port-object range www www
object-group service Windows_VPN_Client tcp
  port-object range pptp pptp
object-group service Trading_i tcp
  port-object range 9999 9999
  port-object range 9005 9006
access-list outside_access_in permit icmp any any
access-list inside_access_in permit udp 192.168.1.0 255.255.255.0 any object-group DNS
access-list inside_access_in permit tcp 192.168.1.0 255.255.255.0 any object-group AllowedPorts
access-list inside_access_in permit tcp host 192.168.1.26 any object-group RemoteDesktop
access-list inside_access_in deny tcp host blt any object-group MSN
access-list inside_access_in permit icmp 192.168.1.0 255.255.255.0 any
access-list inside_access_in permit icmp 192.168.1.0 255.255.255.0 any echo-reply
access-list inside_access_in permit tcp any any object-group sh
access-list inside_access_in permit tcp 192.168.1.0 255.255.255.0 any object-group A
access-list inside_access_in permit tcp 192.168.1.0 255.255.255.0 any object-group BloombergTCP1
access-list inside_access_in permit tcp 192.168.1.0 255.255.255.0 any object-group BloombergTCp2
access-list inside_access_in permit tcp 192.168.1.0 255.255.255.0 any object-group BloombergTCp3
access-list inside_access_in permit udp 192.168.1.0 255.255.255.0 any object-group BloombergUDP
access-list inside_access_in permit tcp host nv1 any object-group MSN
access-list inside_access_in permit tcp host nv2 any object-group Proxy
access-list inside_access_in permit tcp host alLT any object-group MSN
access-list inside_access_in permit tcp any any object-group Gmail
access-list inside_access_in permit tcp any any object-group GmailSMTP
access-list inside_access_in deny tcp host lt any object-group Proxy
access-list inside_access_in permit tcp host IT any object-group Proxy
access-list inside_access_in permit tcp host lt any object-group Anchorfree
access-list inside_access_in permit tcp host nv3 any object-group MSN
access-list inside_access_in permit gre 192.168.1.0 255.255.255.0 any
access-list inside_access_in permit tcp any any object-group Windows_VPN_Client
access-list inside_access_in permit tcp any any object-group Trading_i
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 10.10.10.2 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location lt 255.255.255.255 inside
pdm location A 255.255.255.255 inside
pdm location APC 255.255.255.255 inside
pdm location Desktop 255.255.255.255 inside
pdm location Hm 255.255.255.255 inside
pdm location nv2 255.255.255.255 inside
pdm location nv1 255.255.255.255 inside
pdm location IT 255.255.255.255 inside
pdm location nv3 255.255.255.255 inside
pdm location 192.168.200.0 255.255.255.0 inside
pdm location 192.168.100.0 255.255.255.0 inside
pdm location 192.168.1.26 255.255.255.255 inside
pdm location alLT 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 10.10.10.1 1
route inside 192.168.100.0 255.255.255.0 192.168.1.254 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http lt 255.255.255.255 inside
http 192.168.1.26 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet lt 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.101-192.168.1.194 inside
dhcpd dns 192.168.1.6 213.42.20.20
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain abc.ae
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:7db65e5d22be62a5395fe919a0694854
: end
[OK]

------------------------------------------------------------------------------------------------
0
Comment
Question by:qman2007
  • 2
  • 2
5 Comments
 
LVL 29

Accepted Solution

by:
Alan Huseyin Kayahan earned 1500 total points
ID: 20041287
   Hi gman2007
        Add
          fixup protocol pptp 1723

Regards
0
 

Author Comment

by:qman2007
ID: 20091352
Dear Husy,

Thanks for you help and it worked. Iam going to accept your answer and award you point. But one last question, the same thing i did using pix GUI. I mean did fixup by gui and it didnt worked and after that i posted this question. When i did through command it worked. Any specific reason?

Thanks again.

Regards

Qman
0
 
LVL 6

Expert Comment

by:Booda2us
ID: 20091360
Hello grman2007,
what authentication protocols are you using? Encryption levels?
 Can workstations connect with internet?
 In Win control panel/firewall click on the ADVANCED tab,and then click Settings for Security Logging.
In the Log Setting dialog box, select Log dropped packets and Log successful connections. Note the path and file name in Name
The log file allows you to see where connection errors occur, as well as which source and destination ports the errors occurred on. This log file should provide you with the information needed in case you need to add more ports to the exception list.
I hope this helps...Booda
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 20171217
  Hi gman2007
       In GUI preferences, enable the option "Show the command before sending to device" so when you d some changes, GUI will prompt the Commands that will be applied to device as you click apply. Check if it is the same

Regards
0
 

Author Comment

by:qman2007
ID: 20174874
Dear Husy,

Thanks for your help.

Regards

Qman
0

Featured Post

Identify and Prevent Potential Cyber-threats

Become the white hat who helps safeguard our interconnected world. Transform your career future by earning your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question