Linux dhcp client can't get IP address from dhcp server

Experts:

I cannot get my Linux (Fedora 6) computer to receive an IP address from my dhcp server.  My dhcp server is a Cisco 871 wireless router/switch.  But I am not trying to do this wirelessly.  My Linux box is plugged into a switchport on the 871 using standard cat 5 ethernet cable.  I know the dhcp server is working because I have 3 windows computers that can get IP info from it with no problem.  Everything is on the same 10.10.10.0 private network.

I Recently moved my Linux box home from my office.  At office it has been working fine, but IP address was staticly set in ifcfg-eth0 file.
Now even that does not work!!

Below are the contents of file /etc/sysconfig/network-scripts/ifcfg-eth0:

# VIA Technologies, Inc. VT6102 [Rhine - II]
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Ethernet


If I try to set the IP address manually using the following line, it still won't work.  It accepts the IP address, but if I try to ping another host on the network, it says "destination host unreachable".

ifconfig eth0 10.10.10.61 netmask 255.255.255.0

Help!!!!

Thanks,
Tnic
tayloenicAsked:
Who is Participating?
 
arrkerr1024Connect With a Mentor Commented:
First things first - have you tried that SAME cable and the SAME switch port with another computer?  It could be that either the cable is bad, or that the port you are pluged in to on the cisco is configured for a different vlan than the others.

It could also be that some other strange routes or settings were statically set in other files.  Check /etc/sysconfig/network and see if there is a GATEWAY line in there (redhat does this a lot) - if so that is probably being set to your default GW and is no longer valid on this new network.
Take a look at "route -n" and see what it looks like.
0
 
that1guy15Connect With a Mentor Commented:
Does /etc/sysconfig/network have this line in it?

NETWORKING=yes


http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/s1-dhcp-configuring-client.html

Another alternative is to remove the nic from the box boot it and let Kudzu remove the config. then add the card and it will prompt you to configure it again.
0
 
Kerem ERSOYConnect With a Mentor PresidentCommented:
Hi,

It seems to me that this is a problem with your cisco wireless switch. These ethernet ports a re not a simple siwtch in Cisco 87x series. They are ports of a L4 switch. Meaning you can create VLANs and an even routing in different segments.

Since you can not even work with a manually assigned address I think that this port is placed on a different VLAN etc.

I'll suggest you to connect your box to one of the working outlets with windows to give  a try.

Also try to check yourt Cisco configuration may be there's a MAC filter etc.

0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
http:// thevpn.guruConnect With a Mentor Commented:
try executing
dhclient eth0 #or your network interface
this will launch an IP renew and give u some debug info
0
 
tayloenicAuthor Commented:
Experts:

It turned out to be some problem with Fedora 6.  I disconnected my router and plugged my Comcast cable directly into my Fedora 6 computer, and it worked.  So for some reason, Fedora 6 did not like the dhcp server on my Cisco 871w router.  Then I found a Linux disk that had several live versions on it and tried that.  I found that several distros worked just fine with the dhcp server on my Cisco 871w router.  Damn small linux, sabayan, and gobolinux all received IP address and gave perfect Internet access as soon as they booted.  Puppy linux was not able to get IP address from cisco router.

Soooo.......I guess I will switch to one of those distros, or try Fedora 7, or try Gutsy Gibbon which comes out this week.

Thanks to all of you for responding.

Tnic

0
 
arrkerr1024Commented:
Sheesh, thats ridiculous.  Are you running the latest software for the cisco router (or can you even get updates?).  I run a newer ASA as my home office router and man, the dhcp functionality that cisco provides is total garbage - <rant> in this day and age why can't you even set a reservation, especially on something designed for small office networks!</rant>

Glad you figured it out!
0
 
http:// thevpn.guruCommented:
I have had similar problems with Cisco router DHCP and had to revert to the DHCP server on my linksys wireless router.
0
 
Kerem ERSOYPresidentCommented:
you can try to run wireshark to see what is happeneing in net during dhcp. But different distros having different behaviour for dhcp it is something unusual. I'd suggest you to investigate it further.
0
 
jerrykaCommented:
Hi guys,
Iam very new to linux. I run windows 2003 DC. I installed Linux Mandriva on my laptop. I cannot join this Laptop to the domain. I run the command sudo dhclient and my eth0 is activated, but surprisingly with a foreign ip address that does not exist in my domain. So I have the eth0 activated, but still no internet connection or printing capability. All windows clients are working fine with the DC.
Couls anybody help me with this? Many thanks in advance.
Jerry
0
 
Kerem ERSOYPresidentCommented:
Hi,
Why don't you try to raise a new question? This is not a place to discuss new issues. Also people like you would not be able to find answers to this question once the problem is solved.

Cheers,
K.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.