Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Mapi session exceeded the maximum of 32 objects of type "session"

Posted on 2007-10-09
16
Medium Priority
?
37,118 Views
Last Modified: 2013-01-25
Hi,

I am getting the following on Small Business Server 2003, SP1 with Exchange patched at SP2, and for whichever user this error happens, that particular user will not b able to use outlook.
Event Type:      Error
Event Source:      MSExchangeIS
Event Category:      General
Event ID:      9646
Date:            9/4/2007
Time:            2:04:26 PM
User:            N/A
Computer:      C0SS01
Description:
Mapi session "/o=firstorganisation=Corporate/cn=Recipients/cn=xyzuserr" exceeded the maximum of 32 objects of type "session".

I've tried every registry hack that I've found on EE to workaround this, I've added the MaxOpenMessagesPerLogon key with Session set to 100, I've set "Maximum Allowed Sessions Per User" to 100, I've added a new key MaxObjsPerMapiSession with DWORD value Session set to 100.  I do not see anything in the registry for enabling TCPChimney, and the disabled command returns a "not found" error.

Any suggestions?  I was not planning on patching to SP2 because we are in discussions on a server upgrade.

0
Comment
Question by:forthphaze
  • 5
  • 2
  • 2
  • +6
16 Comments
 
LVL 19

Expert Comment

by:aissim
ID: 20041680
Have you restarted the Exchange services? A simple reboot of the machine will clear up those sessions/connections....at the same time should make those reg changes stick.
0
 
LVL 1

Author Comment

by:forthphaze
ID: 20047642
Yes, I've restarted the services, and I've rebooted the server, the error comes back within a few minutes of users getting back online with Exchange.
0
 
LVL 1

Author Comment

by:forthphaze
ID: 20047723
Possibly relevant information:  the first time this error shows up inthe event log was approximately the same day that I uninstalled Symantec Mail Security for Exchange and moved spam filtering to a service provider.  There is no spam filtering software installed on any of the client PCs, only Symantec's corporate antivirus program.

0
Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

 
LVL 1

Author Comment

by:forthphaze
ID: 20048408
increased point value to 500
0
 
LVL 19

Accepted Solution

by:
aissim earned 1000 total points
ID: 20053088
The 'Maximum Allowed Sessions Per User' would be the setting that is pertinent to your situation - and I'm not sure why it didn't help alleviate the problem.

I would suggest, as this article states (http://support.microsoft.com/kb/842022), trying the fix to 'grant view information store status permissions' if you have not already done so.

Another remedy I have seen in the past is discussed here: http://msexchangeteam.com/archive/2007/07/18/446400.aspx

Which involves disabling the TCP Chimney:
Netsh int ip set chimney DISABLED
0
 
LVL 1

Author Comment

by:forthphaze
ID: 20059412
Thanks, there is nothing in the registry regarding TCPChimney.  I'll try the permissions option. Still  sctratching my head...

0
 

Assisted Solution

by:sobodan
sobodan earned 1000 total points
ID: 20065590
Hey,

You have to add View Information Store permission for every user you want to connect and view his email on the Exchange server. To do this:

"      Grant View Information Store Status permissions to the account under which the program runs

Note Programs that run under an account that has these permissions are not affected by the MAPI sessions-per-user limit.
To grant View Information Store Status permissions, follow these steps:
1.      In Exchange System Manager, right-click the Exchange Server object or the mailbox store to which you want to grant the permissions, and then click Properties.
2.      Click the Security tab.
3.      Click the account to which you want to grant the permissions.

If the account is not listed, click Add, click the account name, click Add, and then click OK.
4.      Under the Allow column, click to select the View information store status check box, if this check box is not already selected.
5.      Click to clear the check boxes for any permissions that are not required, and then click OK.

Note You may have to follow this step if you clicked Add to add the account in step 3. This is because every check box in the Allow column was selected when you added the account in step 3.

Try doing this. Worked for me.
0
 
LVL 1

Author Comment

by:forthphaze
ID: 20081116
After re-doing everything documented on this issue, the problem resolved.  Perhaps I had a typo in my registry entries, I'm not sure, but the do-over fixed me.  Thanks for your help!
0
 

Expert Comment

by:new435
ID: 20197714
I have the same issue and only found 1 of the solutions, the "MaxobjsPerMapiSession" fix and it doesn't seem to have fixed the problem.   WHo knows whatthe real fix is?
0
 

Expert Comment

by:crtg2007
ID: 20330488
Should we be concerned about why there are so many mapi sessions being created by individual users?  I understand this solution works around this issue but it doesn't get at the root problem.
0
 

Expert Comment

by:new435
ID: 20330736
I DONT LIKE PLAYING WITH PERMISSIONS ON FOLDERS.....

I DONT LIKE PLAYING WITH REGISTRY ENTRIES IN ORDER TO UNDERMINE THINGS MICROSOFT DID TO MAKE THE SERVER FASTER AND MORE SECURE (kicking up the 'session' limit), THUS ELIMINATING THE SECURITY BENEFIT.....

I DONT LIKE GRANTING ACCESS TO ANYTHING THAT A USER WASN'T DESIGNED TO HAVE....

I think the answer on this thing is in the NDIS driver issue that aissim speaks about.
0
 
LVL 21

Expert Comment

by:za_mkh
ID: 20430941
The problem here is not with the server itself but the client that is connecting to the Server. They have an underlying network issue that is causing them to get disconnected from the server. But the method in which they disconnect is not clean, so Exchange is unaware that the session is terminated. The next time said person connects, another 'session' is used up until the maximum is reached. That's when they can't connect anymore.

We had this issue with only one person in our organisation. I didn't want to change permissions / reg entries just to get this problem solved. In our case, the person had a dodgy wireless connection which meant that when she was connected via the VPN it created lots of 'orphan' sessions with the Exchange Server. Giving her a new wireless router, resolved our problem!
0
 

Expert Comment

by:fceesay
ID: 21051748
Is there a permanent fix for this.
0
 
LVL 21

Expert Comment

by:za_mkh
ID: 21066126
Yes, sort out the issue with the user/ user's computer that is experiencing the problem. I find that when this problem appears it only affects one or maybe two users. If all my users experienced it daily then I would say Microsoft would have to fix it or I could implement one the many workarounds (but reducing security - I feel) that would negate this problem.
0
 

Expert Comment

by:amdts
ID: 21528626
Just ran into the same issue at a client.  I ran through the article http://msexchangeteam.com/archive/2007/07/18/446400.aspx as aissim suggested and it worked like a charm.  The article says to update the NIC drivers to the version with the latest NDIS version.  The link provided in the article for the Broadcom drivers solved the problem with no other tweaks needed!
0
 

Expert Comment

by:Jac Schroeten
ID: 22476880
Interesting discussion. We appeared to have ran into a similar situation and my internet search brought me here (once again).
We recently moved one of our offices to a new location and for time being a dsl-line was installed untill the lines are delivered. Since the move all users from that office have the same issue, getting their mapi sessions exceeded to 32 and having no access to the exchange server anymore.

Our problem seems to be the temporary dsl which is not sufficient to support our 20 users at the office.
Thanks za_mkh, your adding put us on the right way. We're contacting the dsl provider now to have this solved.
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange database can often fail to mount thereby halting the work of all users connected to it. Finding out why database isn’t mounting is crucial and getting the server back online. Stellar Phoenix Mailbox Exchange Recovery is a champion product t…
Upgrading from older Exchange server to the latest Exchange server can be tiresome, error-prone and risky, without being a seasoned exchange server administrators. It can become even problematic if you're an organization that runs on tight timeline…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

581 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question