We help IT Professionals succeed at work.

iPhoto 08 There were errors installing the software when trying to install just iPhoto

ParadiseITS
ParadiseITS asked
on
1,587 Views
Last Modified: 2013-12-02
My PowerBook 12"867's hard drive up and died on me over the weekend...  so I've got a nice shiny new 80GB 7200rpm drive I put in it and have OS X 10.4.10 installed, updated and all that...

All my pictures were in iPhoto 08 on my previous system, I can copy the iPhoto DB without a problem (whew!) but when I was done with my intial install of OS X and update, the first thing I tried to install was iPhoto 08.  And as soon as I put in my password to allow the install it gave me "There were errors installing the software. Please try installing again"

So, I thought to myself... well.. last time I hade the entire iLife 2004 suite installed and did an upgrade, so maybe that's the problem...  so I installed iLife 04 (iPhoto, iMovie, GarageBand...) and tried the install again... same error.  Found a friend who had the iLife DVD too and tried his thinking my media was corrupted but nope...  still same error.


Anyone have any insight here?  I know Macs pretty well, but just started using iLife a few months ago... can I convert my iPhoto DB?  How can I get iPhoto installed...?
Comment
Watch Question

Eoin OSullivanConsultant
CERTIFIED EXPERT

Commented:
Is there a chance that the copied iPhoto DB has different ownership permissions from the old  mac drive setup?  Is your current username IDENTICAL to that on the PowerBook before the hard disk died?  If not then the iPhotoDB may be "confusing" the new installation.

1. Keep the iPhoto DB backup somewhere else until you get iPhoto 08 up and running.
If you get iPhoto running with a clean - blank database then you can look at replacing it with the backup.

2. If iPhoto 08 will not install then try doing a Repair Permissions with Disk Utility first.  It sounds like some pre-install check is failing

Author

Commented:
Well, this is possible... the username and password are the same... however I can't get it to install w/o the iPhoto DB in place let alone with it in place.  I grabbed a copy of iLife 06 and iPhoto didn't install from that either...


A new development is I got iPhoto Library Manager and extracted the pictures from my iPhoto 08 DB w/o a problem and then fired them up in iPhoto 04.  It seemed to work fine, except my screen saver shows ALL of my iPhoto pics, not just the ones in the Screensaver Album... the last night I went to go in to resort the pictures and iPhoto crashed and now when it comes up "Loading Photos" and quits unexpectedly...   iPhoto is not very good software is it...


So where I am right now... I can install iPhoto 04 and import my pictures into it, which I will do again to rebuild the DB... I tried to repair the DB by loading iPhoto while holding SHIFT/Option but that didn't fix the problem... I can't use iPhoto for a screensaver (which I was doing with 08) and I can't load iPhoto 06 or 08.
Eoin OSullivanConsultant
CERTIFIED EXPERT

Commented:
I am veering towards the opinion that you may have one or several corrupted photos in your database.  This would explain how the system starts loading and then falls-over

A difficult thing to troubleshoot as you may have thousands of photos.

Try the 50/50 system

Create a new clean iPhoto Database.

Import just 50% of the photos .. see does it behave itself.
If it does .. then add 50% of the remainder .. .etc. until you hit upon the problem.

I'm afraid I can't think of another solution at present .. anyone else out there??

Author

Commented:
That's what I am doing in 04 right now...  couldn't think of a better solution.

that still doesn't address the issue to why I can't install 06 or 08 even with a clean DB... which is my initial question... I verified the permissions and they still don't install.
Consultant
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
hmm... a thought... I might backup my DB and try that... I'd reaallly like to upgrade from 04...

Author

Commented:
hmm... those files don't exist now...  nothing to delete... any other ideas?
Eoin OSullivanConsultant
CERTIFIED EXPERT

Commented:
Hmm.. I'm getting stumped here.
Is iPhoto '04 running properly or not?

Author

Commented:
iPhoto is running perfectly, no problems at all... 06 and 08 won't install at all. And neither will iWeb 08 or GaragaBand 08... it's very odd, I think I'll just have to live with it though... I've run across a few people who had the issue and told me they reinstalled OS X which I am not going to do...

Author

Commented:
eoino... I gave you the points because of the amount of effort you put in, even though it wasn't helpful.  Thanks for all your suggestions!
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.