• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7938
  • Last Modified:

Samba smb.conf "create mask" option for shares is not working.

I have the following share defined in smb.conf:

[data]
   path = /home/user/data
   writeable = yes
   valid users = me, them
   force group = them
   create mask = 775

The "force group" option seems to work, but the "create mask" option does not.  All files are created with the 755 mask instead of 775--thus not giving "them" write access to files that "me" creates while using a Windows workstation to access the share.  

Note that I have restarted the samba server (service smb restart) to make sure the settings take effect, but it still doesn't work.
0
kleencoder
Asked:
kleencoder
1 Solution
 
ravenplCommented:
create mask is not the mask file is going to be created. If some bit sare unset in create mask, then they will not be set on resulting file. So with this param You can only restrict some bits - not enchance.
Use
        create mask = 0664
        security mask = 0664
        directory mask = 0775
        directory security mask = 0775
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now