Outlook problem with error 0x80040154 (and others) -- inetcomm issue?

I had to reinstall XP and Office from scratch, including the upgrade to SP2, and Outlook now refuses main contact with my POP3 servers. I'm getting a variety of error messages, principally 0x80040154 but also some others referenced here.

Yes I've tried detect and repair. Yes I've deleted and reinstalled Windows. Yes the exact same POP3 settings work fine on another PC.

Research here and elsewhere suggests the problem might lie with inetcomm.dll, so I tried to reinstall that with regsvr ... but even though I can see a copy of the dll in windows/system, the command 'regsvr32 inetcomm.dll' fails with 'the specified module cannot be found'.

Am I doing something really dumb here? Are here registry settings I need to check first?

Help ...


DJ
djarrett33Asked:
Who is Participating?
 
Computer101Connect With a Mentor Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0
 
war1Commented:
Greetings djarrett33 !

1. Reset the Outlook toolbar template. With Outlook close, do a search for and rename outcmd.dat file. Do the same for frmcache.dat and outlprnt files. Restart Outlook.

Outcmd.dat is located in C:\Documents and Settings\<user>\Application Data\Microsoft\Outlook folder. It is a hidden file, so you have to unhide hidden files. Go to any folder and select Tools > Folders Options > View. Check "Show hidden files and folders". Click OK.

2. Delete and recreate the POP accounts in Outlook.

3. If no joy, an addin may be interfering. Disable Outlook Addins.  Go to Tools > Options > Other > Advanced Options > Addin Manager or COMM/Addins and disable the addins.

4. Check if an external program running in the background is interfering with Outlook. Check Firewall, antivirus, antispyware, antispam, and all Norton programs. Disable these programs one at a time.

5. If no joy, create a new Outlook profile.
http://www.outlook-tips.net/howto/profile.htm

Hope this helps, war1
0
 
djarrett33Author Commented:
Thanks for the comprehensive response, war1-- sadly none of your eminently sensible suggestions worked. Any ideas about the errant inetcomm.dll?
DJ
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
war1Commented:
DJ, you should be able to register inetcomm.dll  You may need to put the entire path for the file  C:\Windows|System32\inetcomm.dll
0
 
djarrett33Author Commented:
Yes, I agree I should -- I have tried it with the full path, and I've even checked that all the capitalizations are correct (regsvr32 C:\WINDOWS\system32\inetcomm.dll, since you ask). A DLL of that name is definitely there, and Explorer identifies it correctly as "Microsoft Internet Messaging API". But running regsvr just produces "LoadLibrary("c:\windows\system32\inetcomm.dll") failed - The specified module could not be found."

This has to be the problem, surely?

DJ
0
 
war1Commented:
DJ,

Run System File Checker and then try registering the file again. Go to Start > Run and type sfc /scannow
0
 
djarrett33Author Commented:
Did that -- no change (and no duff files found, apparently).

How about deleting all instances of inetcomm (and mabe regsvr32) and trying sfc again? Would that pick up the now-missing files and reinsall clean copies? Or should I be hunting around the registry for something?

Tearing my hair out here ... but hey, thanks for your time on this

DJ
0
 
war1Commented:
DJ, since you reiinstall Outlook, the inetcomm.dll should be OK.  I do not know why Windows would not register the file.

Did you create a new profile? The profile may be corrupt.

What is the exact error message?
0
 
war1Commented:
Since you are using Office XP, you should update to SP3. This may fix the problem
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=85af7bfd-6f69-4289-8bd1-eb966bcdfb5e
0
 
djarrett33Author Commented:
Ah, but I already have SP3. Maybe that's the problem ...
0
 
war1Commented:
In your question, you wrote, "I had to reinstall XP and Office from scratch, including the upgrade to SP2..."  That is why I suggested to upgrade to SP3.
0
 
djarrett33Author Commented:
My mistake, sorry. I ran Windows Update after the reinstall and did what it suggested. Which was XP SP2 and Office SP3.
0
 
war1Commented:
diarrett33,

Disable Word as editor.  In Outlook, go to Tools > Options > Mail Format.  Uncheck to the option to make MS Word the editor.  Save changes and then test.
0
 
djarrett33Author Commented:
I never use Word as my mail editor anyhow, but I did verify that the settings are unchecked. Still no joy ...
0
 
war1Commented:
diarrett33,

You have disable all the addins, and the problem persists?

The problem could be SP3 for Outlook 2003.  It is brand new, and some users are experiencing problem with it.  Try to uninstall SP3 to go back to SP2.  You may have to reinstall Outlook 2003 to revert back to earlier service pack.
0
 
djarrett33Author Commented:
Ok, uninstalled Office completely and reinstalled without SP3 and without add-ins. Same problem. It's now starting to drive me nuts ...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.