[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

macro security setting disabled in access 2003 on some PCs on network

Posted on 2007-10-09
8
Medium Priority
?
281 Views
Last Modified: 2013-12-04
On all PC's on the network with Access 2003, the Macro security level can be changed through the toolbar except for 1 PC.  On that PC,  the option to change the macro security via the toolbar is not there?  It's not there but greyed out, it's simply not there.  
I assume a parameter is set, and I do not know where?  The effect this is having is when Access 2003 is used by Visual Basic to print a report, the user is asked each time a macro security question before  previewing the report.  If the security level is lowered, this security question is not asked.  Because the user opens this internally created access database many times each day, the user learns to not read any  security warnings; it's the story of crying 'wolf' one too many times.

 
0
Comment
Question by:dastaub
  • 5
  • 3
8 Comments
 
LVL 65

Accepted Solution

by:
RobSampson earned 1500 total points
ID: 20046725
Try this:

To make the Security command available
1. On the Tools menu, click Customize, and then click the Commands tab.
2. Click Rearrange Commands, click Menu Bar, and then in the Menu Bar box, click Tools | Macro.
3. Under Controls, click the Add button.
The Add Command dialog box appears.
4. In the Categories list, click Tools.
5. In the Commands list, click Security, and then click OK.
The Security command now appears in the Controls list.
6. Use the Move Up and Move Down buttons to position the Security command where you want.
7. Click Close twice.

Source: http://www.hugkc.org/KCAccessSIG/Doc%5C2005_03_Access2003_MacroSecurity.pdf

Regards,

Rob.
0
 

Author Comment

by:dastaub
ID: 20048993
i came across this solution on the web, but it did not work.
0
 
LVL 65

Assisted Solution

by:RobSampson
RobSampson earned 1500 total points
ID: 20052385
What about:
1. On the Tools menu, click Customize, and then click the Commands tab.
2. Click Rearrange Commands, click Menu Bar, and then in the Menu Bar box, click Tools | Macro.
3. Click Reset

Please give information on why this doesn't work....eg, what don't you see...where do you get up to before you cannot see the command?

Regards,

Rob.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 

Author Comment

by:dastaub
ID: 20054729
i performed both set of instructions.  Everything appeared just as described, nohting was missing, and no error messages apeared.  BUT, what continues to show up below Tool - > security on the menu bar is:
Set Database password...
workgroup Administrator...
user and group permissions...
user group and accounts...
user-level security wizard...
encode / decode database...

There continues to NOT be the option to change the macro security level as it apears on all the
other PC's with Access 2003.

0
 
LVL 65

Expert Comment

by:RobSampson
ID: 20062261
Sorry for the delay in getting back to you....unfortunately, I'm not in a position to test this with Access 2003, although I do have other 2003 products.....but have you tried logging on to that machine as a local admin or a domain admin, then see if it appears? If it does, I suspect there is a permissions issue somewhere, but as to where yet, I'm not sure.......

Regards,

Rob.
0
 
LVL 65

Expert Comment

by:RobSampson
ID: 20062271
There may be a registry key for this:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Acess\Security

Understanding Macro Security Levels in Office
http://office.microsoft.com/en-us/ork2003/HA011403181033.aspx

Regards,

Rob.
0
 

Author Comment

by:dastaub
ID: 20069954
i do not know what I did differently, but when I redid your first suggestion for the 3rd time, the menu option to change the macro security level appeared and I was able to change it.

0
 
LVL 65

Expert Comment

by:RobSampson
ID: 20070059
Wow, another one of those unexplainable oddities from M$.....anyway, well done.

Thanks,

Rob.
0

Featured Post

When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft's Excel has many features that most people will never need nor take advantage of.  Conditional formatting is one feature that you may find a necessity once you start using it.
After seeing numerous questions for Dynamic Data Validation I notice that most have used Visual Basic to solve the problem. This suggestion is purely formula based and can be used in multiple rows.
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question