• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 332
  • Last Modified:

Problem with Wired/Wireless Connection

I'm running Ubuntu 7.04 on the most recent update of Parallels 3.0 on an Intel MacBook Pro. My wired connection worked just fine with the fresh install, but I was having issues with getting my wireless connection established. Looking around for a solution, I did what was posted here: http://cattlegrid.net/~christophe/titanium/#AIRPORT

Following that, my airport connection was up and worked like a charm -- until I realized that what I did removed the settings for my wired connection. So I went back and undid the changes I had made, and since then I've not been able to establish a connection to anything, either wired or wireless. What can I do to fix the problem I've gotten myself into, and is there a better way I should go about getting my wireless connection activated in the future?
0
Harry_Truman
Asked:
Harry_Truman
  • 11
  • 10
1 Solution
 
Kerem ERSOYPresidentCommented:
Please post your ifconfig output. Also please post your /etc/network/interfaces contetnts here.
0
 
Harry_TrumanAuthor Commented:
ifconfig output:

eth0      Link encap:Ethernet  HWaddr 00:1C:42:4C:2D:66  
          inet6 addr: fe80::21c:42ff:fe4c:2d66/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3617 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:379812 (370.9 KiB)  TX bytes:810 (810.0 b)
          Interrupt:10 Base address:0x4c00

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:500 (500.0 b)  TX bytes:500 (500.0 b)

-----------------------------------------

etc/network/interfaces

auto lo
iface lo inet loopback


auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

iface eth0 inet dhcp

auto eth0
0
 
Kerem ERSOYPresidentCommented:
ok from the ifconfig output I see that though your eth0 iface is active it does not negotiate an ip address from your dhcerver.
Your /etc/network/interfaces file list concerns me a bit. It reads:
iface eth0 inet dhcp

auto eth0
but it should read:

auto eth0
iface eth0 inet dhcp

Will you modify and try to get an ip address ?

When it comes to the wireless I notice that there are 2 interfaces defined for your wireless adapter:

ath0 (meaning atheros chipset ethernet dirver) and wlan0. Try
ifup ath0
ifup wlan0
anc check your ipconfig again to see which one is up.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Harry_TrumanAuthor Commented:
I changed the interface config file to read:
auto eth0
iface eth0 inet dhcp

But after I saved it, and any time I change it again, it reverts back to:
iface eth0 inet dhcp

auto eth0

Also, I'm at work and not near a wireless network so I can't test whether the wlan setting works.
0
 
Kerem ERSOYPresidentCommented:
please try to stop your networking first:
/etc/init.d/networking stop

it is ok that you are at work. If you don't see a listing of your adapter with ifconfig then you won't be abl to use it. So the first thing to do is to be able to get ifconfig list your wireless ethernet driver
0
 
Harry_TrumanAuthor Commented:
Excellent, that seems to have done it for my wired connection.  As far as my wireless adapter, ath0 is the one that it recognizes; wlan0 returned nothing.
0
 
Harry_TrumanAuthor Commented:
After rebooting, I had to start releasing the IP address and getting a new one:
ifdown eth0
ifup eth0

It releases an IP address every time, so I'm not sure why I'm having to get a new one upon reboot.
0
 
Kerem ERSOYPresidentCommented:
In fact relaseinf an address and renewing it jsut depends on the settings on your dhcp server. If you release an address but can not get the same again after renew it means that it means your DHCP serrvers lease time is very low :) So it has nothing to do with your dhcp client. So it does say anything about your problem :)

In the first part since you've aliased your Wireless Adapter to eth1 (when following th instructions from that guy you've sent the link) we need to look for eth1 rather than ath0 (which is your reeal driver and eth1 is an alias for it.)

Will you try to remove the alias for eth1 an reboot  your paralles Virtual Machine agian ?

0
 
Harry_TrumanAuthor Commented:
Well, I was messing around with trying to change my resolution, and messed up the interface display and just ended up reinstalling the VM again.  I still had to make the same changes that you listed in your second post, though, the only difference this time is that I didn't set eth1 as the alias for ath0.  So, I guess in a round-about way, I removed the alias like you just suggested...
0
 
Kerem ERSOYPresidentCommented:
ok after you have set-up without alias can you get your ath0 interface with ifup. I mean do you see it listed when you issue ifconfig ?
0
 
Harry_TrumanAuthor Commented:
No such device.  Failed to bring up ath0.
0
 
Harry_TrumanAuthor Commented:
KeremE was definitely on the right track, but I have to disagree with the recommendation as my problem was never resolved.
0
 
Kerem ERSOYPresidentCommented:
Sorry my bad :) It seesm that I've abandoned this treat. Shall we continue from where we left ? So that we can solve the problem ?
0
 
Harry_TrumanAuthor Commented:
It's no prob, if you'd like to continue that's fine with me.
0
 
Kerem ERSOYPresidentCommented:
ok will you post your /etc/modprobe.conf ?
0
 
Harry_TrumanAuthor Commented:
Ubuntu has multiple files within /etc/modprobe.d that comprise the modprobe.conf (the file is broken up).  What info are you specifically looking for?
0
 
Kerem ERSOYPresidentCommented:
ok if it has alased one of your therenet /wireless interfaces
0
 
Harry_TrumanAuthor Commented:
There's actually nothing aliased to any of my network adapters, I don't believe...which might explain why I have to ifdown/up eth0 everytime I reboot my VM.

# BlueZ modules
alias net-pf-31 bluez
alias bt-proto-0 l2cap
alias bt-proto-2 sco
alias bt-proto-3 rfcomm
alias bt-proto-4 bnep
alias bt-proto-5 cmtp
alias bt-proto-6 hidp
alias tty-ldisc-15 hci_uart
alias char-major-10-250 hci_vhci
0
 
Kerem ERSOYPresidentCommented:
ok then since you are using parallels I won't expect you to see your wireless dirver as a native Wireless one such as ath0. Since there's this virtualization layer what it will do is to map your physical drivers over your system to virtual ethernetadapters. (which will be bridged a bridged connection for each interface).

So what I suggest you now is check your Parallels configuration console and be sure that:
- you have created 2 different virtual adapters available for your Ubuntu VM
- be sure that each maps a different physical ethernet. I am not sure for MQC but in PC you just enable bi
bridging for each interface and pair a physical interface with a virtual one.

Since you Paralles server will map phys to virtual drives I think you must be seeing 2 ethernets instead of one eth and one wireless. In this case you will be able to make wireless settings only over your Hhost OS not the VM.

0
 
Harry_TrumanAuthor Commented:
Hmm, I guess that would've been the easiest thing to do from the beginning.  Should've just added the second adapter through Parallels instead of trying to get it recognized natively through Ubuntu.  I'll alias it like I did the first time and that will be that.  Thanks for the help, it's been much appreciated.
0
 
Kerem ERSOYPresidentCommented:
I don't think you haeve and option do detect a native hardware interface from within a guest OS.  Al you could be able to detect is what your parallels show you instead. This is why I told you should be detecting it as an ethx interdace isntead of the native one.
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

  • 11
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now