We help IT Professionals succeed at work.

how do i configure exchange on sbs2003 for external mail?

274 Views
Last Modified: 2008-02-07
Currently we have a sbs2003 network with internal mail (.local). we would like to get rid of everyones .local address and configure it for their .com address. can you please let me know what i need to do to achieve this? here is what Im thinking so far:

1. at their domain registrar have the mail. point to their public static ip address. have the mx record be mail.theirdomain.com
2. forward port 25 to sbs2003 server on firewall
3. in exchange system manager go to recipients -> recipient policies and go into the default policy and change the .local address to the .com address. (is this necessary?)
4. go into each user account and make sure they have theirdomain.com email address in the list, make it default address.
5. configure smarthost to route mail through their isp (verizon)

Based on these steps, when their server gets mail destined to theirdomain.com it will route it to the appropriate mailbox?

What else do I need to do?

Jason
Comment
Watch Question

IT manager
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
so basically do 1 and 2. then run the internet connection wizard, then do step 5? and yes, it is only 1 domain.
tigermattSite Reliability Engineer
CERTIFIED EXPERT
Most Valuable Expert 2011
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
tigermattSite Reliability Engineer
CERTIFIED EXPERT
Most Valuable Expert 2011

Commented:
Oh, and yes, since mail is delivered direct to the server, Exchange will find the mailbox which has the @<domain>.com email address and deliver the message to it. Obviously if it doesn't exist an NDR will be generated.

<useful info> In theory, you could send an email manually from outside using the .local address through telnet, it would still work since Exchange knows the .local address is tied to a mailbox. However, typing this into say Yahoo and trying to send wouldn't since it wouldn't have a clue what @<internaldomain>.local was, as it isn't registered on public DNS nor does it have an MX record. </useful info>

-tigermatt
Dave StringfellowIT manager

Commented:
yes, you may need to change the email addresses to fit your convension, but it will creat everything you need.
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
tigermattSite Reliability Engineer
CERTIFIED EXPERT
Most Valuable Expert 2011

Commented:
I've never come across a method of setting up outgoing authentication, so I guess if the SMTP server requires this it has to be done manually?

As per:

http://www.amset.info/exchange/smtp-connector.asp. Follow the steps to open your SMTP connector properties (configured with the wizard), then the questions section at the end of the page has a part explaining where to set your username and password for authentication.

-tigermatt
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
Rarely does an Internet Access Provider require outgoing authentication for using their Smart Host.  But if they did, then it would be configured on the SmallBusiness SMTP Connector.

Jeff
TechSoEasy
tigermattSite Reliability Engineer
CERTIFIED EXPERT
Most Valuable Expert 2011

Commented:
Many of the ones over here in the UK do, the ISPs and web hosts require it, and others restrict access to only their own IP range. Perhaps it's different where you are? :-)

-tigermatt
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
True... but he stated it's Verizon.
tigermattSite Reliability Engineer
CERTIFIED EXPERT
Most Valuable Expert 2011

Commented:
OK, fair enough, you win! ;-)
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
Yeah!  :-)

Author

Commented:
yeah, i've setup the smarthost using verizon for 2 other clients and it requires authentication.
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
damn... I lost.
tigermattSite Reliability Engineer
CERTIFIED EXPERT
Most Valuable Expert 2011

Commented:
Lol ;-)

Author

Commented:
Thanks everyone for your help, i had zero problems. here is what i did:

1. Changed the A record at the domain registrar to point to their static IP address (MX record was already there)
2. forwarded port 25 to sbs2003 server on the firewall
3. Ran the Configure Email and Internet Connection Wizard using the guidance of the link techsoeasy provided http://sbsurl.com/ceicw

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.