?
Solved

access home PC through RDP

Posted on 2007-10-10
4
Medium Priority
?
707 Views
Last Modified: 2013-12-14
I am attempting to access my home computer while at work using Remote Desktop.  Both computers are running Windows XP Professional.  I have a cable modem connection at home which is shared by multiple computers through a Netgear router.  If I attempt to access the home computer from another computer on my home network, it works just fine.  However, in this situation, I am able to use the internal IP address (not sure if that is what it is called) which is assigned by the router.  So for example, I can use computer A (192.168.0.100) to access Computer B (192.168.0.103) and it works just fine.

Obviously, these IP addresses are not available outside of my home network, so what IP address to I use to connect to the target machine?  I located what my external IP address is, but attempting to connect to that IP address fails.  WIndows Firewall is disabled, and I have gone into the settings on my Netgear router and made sure it is set up to allow remote desktop connections.

Is there something more that I need to do?  Also, today I am working from home and using VPN to access my work computer.  Is testing the connection from this computer (connected through a VPN connection) a realistic simulation of what I will experience when I am at work, or is this just making the matter more complicated?

0
Comment
Question by:peterxlane
3 Comments
 
LVL 2

Accepted Solution

by:
FSchaffer earned 672 total points
ID: 20049947
All Ip addresses must be static and you must forward the RDP port 3389 on the router to the machine you want to connect to.
0
 
LVL 2

Assisted Solution

by:Olski
Olski earned 672 total points
ID: 20049984
You will need to setup port forwarding on your router to the internal IP address on the PC you want to connect to. The default port RDP uses is 3389, so you will need to add a service on your netgear router (call it RDP or what ever you like) set it to TCP and port from 3389, port to 3389. Then go in to ports on your router menu and add the serice you just created and enter the internal IP address of the PC you wish to connect to, e.g. 192.168.0.100. The Microsoft FAQ on Remote Desktop can be found here: http://www.microsoft.com/windowsxp/using/mobility/rdfaq.mspx

If you need some more help, please feel free to ask.
0
 
LVL 33

Assisted Solution

by:CarlWarner
CarlWarner earned 672 total points
ID: 20052177
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
Last month, the FCC voted to repeal Title II, the framework supporting net neutrality across all broadband ISPs. We sat down with Doug Walton, database administrator at Experts Exchange to gauge his opinion of what will happen next.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question