Restore TCP/IP NetBIOS helper service

I am still trying to fix a group policy related problem with 2 of our servers. Please see my other post for more background info. My current question involves restoring th above service/driver.

I currently cannot start the above service. It fails with "Error 1705:The dependency service does not exist or has been marked for deletion." This happens on both servers. Most of the KB articles I found have exact symptoms as ours; however they all say that the above service must be running on all servers. So I dug around and found out that in device manager under non PnP device drivers there is NOT an option for "NetBios over Tcpip" as there is for all my other servers.

I tried deleting the file, which is "nbt.sys" , from the problem server and copying it from another working server and placing it in the correct directory to no avail. After restarting nothing had changed. So how do I get the service to start and/or get an entry under the drivers section? The missing driver is consistent on both servers that can't start the service. One is a domain controller and the other is user server.

Isn't this service part of the TCP/IP stack? If so, shouldn't a reinstall of TCP/IP get it back to normal? I also checked before and  the file "nbt.sys" was present on the problem servers and in the correct path. Could this file have just gotten corrupted?

I have tried all 3 settings in the LAN propeties regarding NetBIOS, i.e "enable NetBIOS over TCP/IP."
goodman1210Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Netman66Connect With a Mentor Commented:
See if resetting the TCP/IP stack fixes it for you.

http://support.microsoft.com/kb/317518

Make sure you enter all the IP information back into the NIC after this or you're server won't have any known addresses.
0
 
goodman1210Author Commented:
317518 is a good one, but KB325356 is what did it. I actually tried the one you linked to no avail. Some lucky seacrhing let me find http://support.microsoft.com/kb/325356/en-us which did the trick. I performed the process exactly as written on my domain controller and the only thing I changed on the user server was that I used safe mode with networking rather than directory services restore mode.

Your fix will prob work for some so I'll award half points. Restarting the service esentially fixed ALL of the myriad of problems I was having on these 2 servers.

Thanks
0
 
goodman1210Author Commented:
I should also mention that the differenc between those 2 articles is that the process for the onle I listed involves manually deleting the Winsock keys and editing nettcpip.inf The link that Netman posted is supposed to do the same thing, however it only worked for me if I manually deleted/edited everything.
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
Netman66Commented:
I think the key difference may be that your link references fixing it on a DC - which may be why my link didn't completely work even though it essentially does the same thing.

I appreciate the reward!
NM
0
 
goodman1210Author Commented:
One of my servers was a DC. So I used some deductive reasoning and figured that Safe mode with networking would be the best bet. I'm still not sure why the resetting article didn't work.
0
 
Netman66Commented:
Glad it's fixed regardless.

Thanks for the info - this question will be useful to others.
0
All Courses

From novice to tech pro — start learning today.