Remote Desktop Error (Machine Specific it seems)

Posted on 2007-10-10
Last Modified: 2013-11-21
OK So I get the error of

"The remote computer dissconnected the session because of an error in the licensing protocol.  Please try connecting to the remote computer again or contact your system administrator."

on two computers that try to connect to on specific terminal server.

I have tried the deleting of registry keys and everything to no avail.  

I can get to the terminal server from my desktop but I cannot from my laptop.

Any suggestions?
Question by:Goofdru
    LVL 3

    Expert Comment

    What are you connecting to?  
    A terminal server with licenses or remote administration terminal services?

    Sound somewhat like your license server is offline, not being seen or corrupted.

    Author Comment

    No it is online because I am on it right now on my desktop, trying to see if I see anything weird.  It is a terminal server with licenses, 15 to be exact per seat.  It is not accessed very often but now that a few people have gotten new PC's I don't know what to do.

    LVL 3

    Expert Comment

    It may not be a licensing issue, the error doesn't seem to point to that, but it could be.  

    Check the logs to see if you get any more detail on the error.

    Also, per seat, means per machine.  So if you have connected from 15 different machines you would be out of licenses.  Assuming it is recording them correctly.

    Check the license server and remove any machines that no longer need access.  

    If the server is a 2003 box, and you have local admin rights, try connecting to the console by starting Remote desktop with the console switch  (mstsc.exe /console)  That would bypass any licensing issues.

    Author Comment

    Well this is what I have found out.

    There is an error on the TS Application event log saying that it cannot contact the license service on our domain controller.  Which this is becoming a Cluster F anyway, but the TS is a W2K TS and the domain controller is a W2K3 server.

    So after finding that the domain controller didn't have the license logging service started, I started it and now I am getting an error in the System log of:

    "Terminal Services Licensing can only be run on Domain Controllers or Server in a Workgroup.  See Terminal Server Licensing help topic for more information. "


    "The Terminal Services Licensing service terminated with service-specific error 29. "

    In the application log when I try to connect from a different computer.  Yet the PC's that have worked before are still working.
    "The terminal server cannot issue a client license. "

    Author Comment

    I am sorry all errors are in teh System log
    LVL 3

    Accepted Solution

    The error doesn't make sense if this machine is the DC...  

    I would start with uninstalling the TS license service and then re-installing it on the domain controller.   Add/remove programs would have this.

    None of this is going to work right without fixing this issue.  There is a default amount of machines TS will allow to connect w/o a running license server and there used to be time limitation also.

    After getting the service running on the DC you may have to tweak the registry on the TS box to point directly to it even though you shouldn't have to do this.  I have seen it before.  I'll look to see if I can find the exact registry tweak to do that part in the mean time.


    Featured Post

    Threat Intelligence Starter Resources

    Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

    Join & Write a Comment

    Suggested Solutions

    Title # Comments Views Activity
    GPO's not appliec 3 57
    Remoteapps on a server which is a Dc 3 39
    Windows software question 5 36
    Bios changes 5 23
    Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip is around source server preparation. No migration is an easy migration, there is a…
    Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    24 Experts available now in Live!

    Get 1:1 Help Now